ISO 639-1 ye la primer parte del códigu ISO 639. Consiste en 204 códigos de dos lletres usaos pa identificar los idiomes principales del mundu. Estos códigos son una taquigrafía internacional bien útil pa indicar idiomes. Por casu: L'inglés ta representáu por en L'alemán ta representáu por de (del endónimu Deutsch) El xaponés ta representáu por ja (anque'l so endónimu ye Nihongo)

La llista de códigos ISO 639-1 aportó a una norma oficial nel 2002, pero esistió en formatu borrador años tras. L'últimu códigu añadíu foi ht, representando al creole haitianu'l 26 de febreru de 2003. L'usu de la norma foi sofitáu por IETF language tags, introducíu por RFC 1766 en marzu de 1995, y siguíu por RFC 3066 en xineru de 2001 y por RFC 4646 en setiembre de 2006.

Nun s'añaden nuevos códigos ISO 639-1 a les llingües que tengan códigu ISO 639-2 propiu. Los sistemes qu'usen códigos ISO 639-1 y 639-2 con códigu 639-1 preferíu, nun tienen que camudar los sos códigos.

Si un códigu ISO 639-2 que cubre un grupu de llingües ye usáu, puede volvese obsoletu por un códigu ISO 639-1 pa dellos datos.

+ Códigos ISO 639-1 agregos dempués de la publicación del RFC en xineru de 2001ISO 639-1ISO 639-2NomeFecha d'agreguCubiertu primero porioidoIdo15-01-2002artwawlnValón29-01-2002roalilimLimburgués02-08-2002gemiiiiiYi de Sichuán14-10-2002sitanargAragonés23-12-2002roahthatCreole haitianu26-02-2003cpf

Llista idiomes De siguío, la llista de llingües ordenaes alfabéticamente siguiendo l'estándar ISO 639-1

aa afarab abkhasuae avésticoaf afrikaansak akanoam amháricuan aragonésar árabeas asamésav avar (o ávaro)ai aimaraaz azerbaixanuba baskirbe bielorrusubg búlgarubh bhoyapuríbi bislamabm bambarabn bengalíbo tibetanubr bretónbs bosniuca catalánce chechenoch chamorruco corsucr creecs checucu eslavu eclesiásticu antiguucv chuvasiocy galésda danésde alemándv maldivianu (o dhivehi)dz dzongkhaee ewéel griegu (modernu)en ingléseo esperantues español (o castellán)et estoniueu euskerafa persaff fulafi finés (o finlandés)fj fixanu (o fixi)fo feroésfr francésfy frisón (o frisio)ga irlandés (o gaélicu)gd gaélicu escocésgl gallegugn guaranígu guyaratí (o guyaratí)gv manés (gaélicu manés o d'Isla de Man)hai ḥausahe hebréuhi hindi (o hindú)ho hiri motuhr croataht haitianuhu húngaruhy armeniuhz hereroia interlinguaid indonesiuie occidentalig igboii yi de Sichuánik iñupiaqio Idois islandésit italianuiu inuktitut (o inuit)ja xaponésjv javanéska xeorxanukg kongo (o kikongo)ki kikuyukj kuanyamakk cazacu (o kazajio)kl groenlandés (o kalaallisut)km camboyanu (o jemer)kn canarésko coreanukr kanuriks cachemiro (o cachemir)ku curdukv komikw córnicuky kirguísla llatínlb luxemburguéslg lugandali limburguésln lingalalo laolt lituanulu luba-katanga (o chiluba)lv letónmg malgax (o malagasy)mh marshalésmi maorímk macedoniuml malayalammn mongolmr maratíms malayumt maltésmy birmanuna nauruanonb noruegu bokmålnd ndebele del nortene nepalésng ndonganl neerlandés (o holandés)nn nynorskno noruegunr ndebele del surnv navajony chichewaoc occitanuoj ojibwaom oromoor oriyaos osético (o osetiu, o oseta)pa panyabí (o penyabi)pi palipl polacups pastú (o pastún, o pashto)pt portuguésqu quechuarm romanchern kirundiro rumanuru rusurw ruandés (o kiñaruanda)sa sánscritusc sardusd sindhise sami septentrionalsg sangosi cingaléssk eslovacusl eslovenusm samoanusn shonaso somalínsq albanéssr serbiuss suazi (o swati, o siSwati)st sesothosu sundanés (o sondanés)sv suecusw suaḥilita tamilte télugutg taxiquistanínth tailandésti tigriñatk turcomanutl tagalutn setswanato tonganotr turcuts tsongatt tártarutw twity tahitianuug uiguruk ucraínur urdúuz uzbekuve vendavi vietnamitavo volapükwa valónwo wolofxh xhosayi yídish (o yidis, o yiddish)yo yorubaza chuan (o chuang, o zhuang)zh chinuzu zulú Tabla de códigos asignaos o acutaos La siguiente tabla amuesa una de les trés partes de la norma ISO 639-1. Tamién dexa que, faciendo clic nun elementu de códigu, vaya a la páxina de la enciclopedia que detalla la información de los códigos ISO 639-1 correspondientes a cada país.

Tabla de códigos ISO 639-1-1 asignaos y utilizaosAA AfarAB AbkhasuACADAE AvésticoAF AfrikaansAGAHAIAJAK AkanoA ELAM AmháricuAN AragonésAOAPAQAR ÁrabeAS AsamésATAUAV AvarAWAXAI AimaraAZ AzerbaixanuBA BaskirBBBCBDBE BielorrusuBFBG BúlgaruBH BhoyapuríBI BislamaBJBKBLBM BambaraBN BengalíBO TibetanuBPBQ<tt>BR BretónBS Bosniu BTBUBVBWBXBYBZCA CatalánCBCCCDCE ChechenoCFCGCH ChamorruCICJCKCLCMCNCO CorsuCPCCCR CreeCS ChecuCTCU EslavuCVCWCXCYCZDA Danés DBDCDDDE AlemánDFDGDHDIDJDKDLDMDNDODPDQDRDSDTDUDV MaldivianuDWDXDYDZ DzongkhaEAEBECEDEE EwéEFEGEHEIEJEKEL GrieguEMEN InglésEO EsperantuEPEQERES EspañolET EstoniuEU EuskeraEVETEXEYEZFA PersaFBFCFDFEFF FulaFGFHFI FinésFJ FixanuFKFLFMFNFO FeroésFPFQFR FrancésFSFTFUFVFWFXFY FrisónFZGA IrlandésGBGCGD Gaélicu escocésGUEGFGGGHGIGJGKGL GallegoGMGN GuaraníGOGPGQGRGSGTGU GuyaratíGV ManésGWGXGYGZHAI ḤausaHBHCHDHE HebréuHFHGHHHI HindiHJHKHLHMHNHO HirimotuHPHQHR CroataHSHT HaitianuHU HúngaruHVHWHXHY ArmeniuHZ HereroIA InterlinguaIBICID IndonesiuIE OccidentalIF Igbo IG IH II Yi de Sichuán IJ IK Iñupiaq IL IM IN IO Ido IP IQ DIR IS Islandés IT Italianu IX Inuktitut IV IW IX IY IZ JA XaponésJBJC JD JEJFJGJHJIJJJKJL JM JN JO JP JQ JR JS JT JU JV JavanésJW JX JY JZKA Xeorxanu KBKCKDKEKFKG KongoKHKI KikuyuKJ KuanyamaKK CazacuKL GroenlandésKM CamboyanuKN CanarésKO CorenaoKPKQKR KanuriKS CachemirKTKU CurduKV KomiKW CórnicuKXKY KirguísKZLA LlatínLB LuxemburguésLCLDLELF LugandaLGLHLILJLKLLLMLNLO LaoLPLQLRLSLT LituanuLU Luba-katangaLV LetónLWLXLYLZMAMBMC MD ME MF MG Malgax MH Marshalés MI Maorí MJ MK Macedoniu ML Malayam MM Mongol MN MO MP MQ MR Maratí MS Malayu MT Maltés MU MV MW MX MY Birmanu MZ NA NauruanoNB Noruegu BokmålNCND Ndebele del norteNE NepalésNF NG Ndonga NH NIN NJ NK NL Neerlandés NM NN Nynorsk NO Noruegu NP NQ NR Ndebele del sur NS NT NU NV Navajo NW NX NY Chichewa NZ OA OB OC Occitanu OD OE OF OG OH OI OJ Ojibwa OK OL OM Oromo ON OO OP OO OR Oriya OS Osetiu OT OU OV OW OX OY OZ PA PanyabíPBPCPDPEPFPGPHPI PaliPJ PK PL Polacu PM PN PO PP PQ PR PS Pastún PT Portugués PU PV PW PX PY PZ QAQBQCQDQE QF QG QH QI QJ QK QL QM QN QO QP QQ QR QS QT QU Quechua QV QW QX QY QZ RA RB RC RD RERF RG RH RI RJ RK RL RM Romanche RN Kirundi RO Rumanu RP RQ RR RS RT RU RusuRV RW Ruandés RX RY RZ SA SánscrituSBSC SarduSD SindhiSE SamiSFSG SangoSH SI Cingalés SJ SK Eslovacu SL Eslovenu SM Samoanu SN Shona SO Somalín SP SQ Albanés SR Serbiu SS Suazi ST Sesotho SU Sundanés SV Suecu SW Suaḥili SX SY SZTA TamilTB Télugu TC TD TE TF TG Taxiquistanín TH Tailandés TI Tigriña TJ TK Turcomanu TL Tagalu TM TN Setswana TO Tongano TP TQ TR Turcu TS Tsonga TT Tártaru EL TO TV TW Twi TX TY Tahitianu TZ UAUB UC UD XE UF UG Uigur UH UI UJ UK Ucraín UL UM UN UO UP UQ UR Urdú US UT UU UV UW UX UY UZ Uzbecu VA VB VC VD VE Vienda VF VG VH VI Vietnamita VJ VK VL VM VN VO Volapük VP VQ VR VS VT VU VV VW VX VY VZ WA Valón WB WC WD WE WF WG WH WI WJ WK WL WM WN WO Wólof WP WQ WR WS WT WU WV WW WX WY WZ XA XB XC XD XE XF XG XH Xhosa XI XJ XK XL XM XN XO XP XQ XR XS XT XU XV XW XX XY XZ YÁ YB YC YD YE YF YG YH YI Yídish YJ YK YL YM YN YO Yoruba YP YQ YR YS YT YU YV YW YX YY YZ ZA ZB ZC ZD ZE ZF ZG ZH Chinu ZI ZJ ZK ZL ZM ZN ZO ZP ZQ ZR ZS ZT ZU Zulú ZV ZW ZX ZY ZZ Lleendes de los colores de les celdes ColorEstáuSignificáu    Códigu oficialmente asignáucolspan="18" bgcolor="#FFFFFF" style="color:#000000"|Códigu oficial del idioma indicáu, según ISO 639-1.    Códigu ensin asignarCódigu ensin asignar nin reserváu anguaño, na norma ISO 3166-1 Códigu oficialmente asignáu a llingua con más de 500.000.000 falantes (Top 3) Clasificación según Ethnologue de 2015 Códigu oficialmente asignáu a llingua con más de 250.000.000 falantes (Top 5) Códigu oficialmente asignáu a llingua con más de 200.000.000 falantes (Top 10)

Ver tamién Idioma ISO 639-2 ISO 639-3 Organización Internacional de Normalización

Referencies

Enllaces esternos ISO 639-1/RA. ISO 639-1:2002 standard.

Categoría:Llingües #00639-1 Categoría:Internacionalización y llocalización Categoría:Wikipedia:Páxines con tables frañíes