U arhitekturi internet adresiranja, privatna mreža je mreža koja koristi prostor rezervisan za privatne IP adrese. IPv4 i IPv6 specifikacije definišu privatne raspone adresa. Ove adrese se obično koriste za lokalne mreže (LAN) u kućnim, kancelarijskim i poslovnim okruženjima. Rezervacija privatnih adresa je bila jedna od ideja da se odgodi iscrpljivanje IPv4 adresa.
Privatne mrežne adrese, za razliku od javnih, se ne dodjeljuju nijednoj određenoj organizaciji i svako može koristiti te adrese bez odobrenja regionalnog internetskog registra. Međutim, IP paketi adresirani na takve adrese ne mogu biti prenošeni preko javnog Interneta .
Privatne IPv4 adrese RFC1918 Raspon IP adresa Broj adresa Najveći CIDR blok (Subnet) Veličina ID hosta Mask bits Klasna mreža 24-bitni blok 10.0.0.0 - 10.255.255.255 16.777.216 10.0.0.0/8 (255.0.0.0) 24 bita 8 bita jedna mreža A klase 20-bitni blok 172.16.0.0 - 172.31.255.255 1.048.576 172.16.0.0/12 (255.240.0.0) 20 bita 12 bita 16 susjednih mreža klase B 16-bitni blok 192.168.0.0 - 192.168.255.255 65.536 192.168.0.0/16 (255.255.0.0) 16 bita 16 bita 256 susjednih mreža klase C
Privatne IPv6 adrese RFC 4193 Blok Prefiks/L Globalni ID (nasumični) ID subneta Broj adresa u subnetu 48 bita 16 bita 64 bita fd00 :: / 8 fd xx: xxxx: xxxx yyyy 18 446 744 073 709 551 616
RFC dokumenti
RFC 1918 – "Dodjela adrese za privatne internete" RFC 2036 – "Zapažanja o upotrebi komponenti adresnog prostora klase A unutar Interneta" RFC 7020 – "The Internet Number Registry System" RFC 2101 – "Ponašanje IPv4 adresa danas" RFC 2663 – "Network Address Translator (NAT) Terminologija" RFC 3022 – "Tradicionalni NAT" RFC 3330 – "Posebne IPv4 adrese" (zamijenjene) RFC 3879 – "Odbacivanje lokalnih adresa" RFC 3927 – "Dinamička konfiguracija IPv4" RFC 4193 – "Jedinstvene lokalne IPv6 unicast adrese" RFC 5735 – "Posebne IPv4 adrese" (zamijenjene) RFC 6598 – "Rezervisani IPv4 prefiks za zajednički adresni prostor" RFC 6890 – "Posebne IP adrese"
Također pogledajte
Heartbeat mreža Intranet, privatna mreža Localhost Rezervirane IP adrese
Reference
Kategorija:Internetska arhitektura