Host Identity Protocol (zkratka HIP) je v informatice hostitelská identifikační technologie, která se používá na IP sítích, jako je Internet. Internet má dva hlavní jmenné prostory, IP adresy a systém doménových jmen (DNS). HIP odděluje cílový identifikační bod a lokátor funkcí IP adres. To pak přináší tzv. Host Identity (HI) jmenný prostor, který je založen na bezpečnostní infrastruktuře veřejných klíčů.

HIP nabízí bezpečné metody pro IP multihoming a mobilní výpočetní techniku.

V sítích, které implementují HIP, jsou v aplikacích všechny výskyty IP adres odstraněny a nahrazeny kryptografickými hostitelskými identifikátory. Kryptografické klíče jsou typicky, ale ne nezbytně, samy vytvářeny.

Vliv odstraňování IP adres v aplikační a transportní vrstvě, vede k oddělení transportní vrstvy od síťové vrstvy v TCP/IP.RFC 4423, Host Identity Protocol (HIP) Architecture, Section 4.1

HIP byl stanoven pracovní skupinou z komise Internet Engineering Task Force (IETF). Výzkumná skupina zabývající se HIP z organizace Internet Research Task Force (IRTF) se zaměřuje na širší dopady této technologie.

Pracovní skupina je autorizována k vytváření RFC v experimentálním směru, ale je pochopitelné, že jejich kvalita a bezpečnostní vlastnosti by měly odpovídat požadavkům sledující standardy. Hlavním smyslem při vytváření těchto experimentálních prací, namísto prací ve standardním směru, jsou neznámé vlivy, které mohou mít tyto mechanismy v aplikacích a na Internetu ve velkém.

Odkazy

Reference

RFC reference RFC 4423 – Host Identity Protocol (HIP) Architecture (early "informational" snapshot) RFC 5201 – Host Identity Protocol base RFC 5202 – Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP) RFC 5203 – Host Identity Protocol (HIP) Registration Extension RFC 5204 – Host Identity Protocol (HIP) Rendezvous Extension RFC 5205 – Host Identity Protocol (HIP) Domain Name System (DNS) Extension RFC 5206 – End-Host Mobility and Multihoming with the Host Identity Protocol RFC 5207 – NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication

Související články IPsec Mobile IP

Externí odkazy IETF HIP working group IRTF HIP research group OpenHIP Wiki How HIP works – from InfraHIP site HIP simulation framework for OMNeT++

Kategorie:Síťová architektura