DomainKeys Identified Mail (zkratka DKIM, v překladu e-mail podepsaný doménovým klíčem) je v informatice nástroj umožňující elektronicky podepsat hlavičky odcházejících e-mailů. DKIM takto umožňuje, aby příjemce mohl zjistit, zda e-mail skutečně pochází ze zdroje, který je uveden jako adresa odesílatele. Ověření DKIM podpisu v přijatém e-mailu je možné pomocí veřejného klíče uvedeného v internetové doméně odesílatele. DKIM spolupracuje s DMARC.
Současná základní specifikace DKIM je RFC 6376, publikovaná jako internetový standard; pozdější RFC aktualizovala zejména kryptografické algoritmy a použití klíčů. Veřejný klíč se vyhledává v DNS podle selektoru uvedeného v hlavičce podpisu, typicky pod názvem ve tvaru selector._domainkey.example.com. V běžné e-mailové autentizaci se DKIM používá společně se SPF a DMARC.
Podpora DKIM DKIM je podporován velkými freemailovými službami jako je Yahoo!, Gmail, AOL, FastMail, ale i český Seznam.cz.
Historie Původní DomainKeys vyvíjel Mark Delany ve firmě Yahoo! od roku 2004 a na základě mnoha připomínek jej publikoval v roce 2007 v RFC 4870. Ve stejném roce pak došlo ke spojení DomainKeys a Identified Internet Mail podle RFC 4871 pod označením DKIM (DomainKeys Identified Mail). V srpnu 2009 vyšlo RFC 5672, kde došlo k upřesnění standardu. V září 2011 byly obě RFC sjednoceny do RFC 6376 (kompatibilita s původními DomainKeys byla zachována). Spojení těchto dvou specifikací byl základ pro sérii IETF dokumentů, které daly vzniknout Internetovému standardu STD 76.
Reference
Související články Author Domain Signing Practices DomainKeys PGP S/MIME Email authentication
Externí odkazy Seznam.cz Email zpřísňuje svoji antispamovou politiku. Nově přidává nutnost identifikace domény pomocí DKIM Pavel Satrapa: DKIM – dopisy ověřeného původu Ondřej Caletka: DKIM podpisy pro důvěryhodnější e-mail
Kategorie:Elektronická pošta Kategorie:Filtrování spamu Kategorie:Počítačová bezpečnost Kategorie:Kryptografie