HTTP/2 je druhá hlavní verze protokolu HTTP. Protokol HTTP je hlavním protokolem webu, je používán pro přenos webových stránek mezi webovým serverem a klientem (webovým prohlížečem). Ideově vychází z experimentálního protokolu SPDY, který vyvíjel Google. Specifikace HTTP/2 byla publikována jako RFC 7540 v květnu 2015. Standardizační úsilí podpořily webové prohlížeče Chrome, Opera, Firefox, Internet Explorer 11, Safari, Amazon Silk a Edge, takže většina hlavních prohlížečů přidala podporu HTTP/2 ke konci roku 2015.

Podle W3Techs podporovalo HTTP/2 na konci února 2017 již 12,1 % webů, v květnu 2018 pak 25,9 % z top 10 miliónu webů.

Vývoj HTTP/2 byl vyvíjen pracovní skupinou httpbis (bis znamenalo „druhý“) pod hlavičkou IEEE. HTTP/2 je první nová verze HTTP protokolu od vydání HTTP 1.1 v roce 1997 jako RFC 2068. Pracovní skupina prezentovala HTTP/2 před IESG ke zvážení jako návrh nového standardu v prosinci 2014, což IESG schválila 17. února 2015. Specifikace HTTP/2 byla publikována jako RFC 7540 v květnu 2015 a hned následující RFC 7541 specifikuje formát komprese hlaviček pro HTTP/2.

HTTPS/2 přímo nevyžaduje zabezpečení přenosu šifrováním (TLS), avšak běžné implementace webových prohlížečů ho vynucují.

Kritika Schvalování nového HTTP protokolu bylo označeno za příliš rychlé, takže nedovolilo vznesení konkurenčních návrhů a bylo vycházeno pouze z existujícího protokolu SPDY. Dále bylo kritizováno zasahovaní do jiných vrstev (řízení toku patří do TCP). Nejvíce kritiky však směřovalo na otázku šifrování.

Podpora Apache podporuje HTTP/2 od verze 2.4.12 (externí modul mod_h2), nativně pak od verze 2.4.17 (modul přejmenován na mod_http2) od října 2015. Staré verze SPDY jsou podporovány modulem mod_spdy, ale vývoj byl už zastaven. Microsoft IIS podporuje HTTP/2 ve Windows 10 a Windows Server 2016.

Odkazy

Reference

Související články SPDY QUIC HTTP/3 WebSocket HTTP pipelining

Externí odkazy

RFC 7540 (anglicky) RFC 7541 (anglicky)

Kategorie:HTTP