Gpg4win (GNU Privacy Guard for Windows) je svobodný software pro šifrování souborů a e-mailů dle standardu OpenPGP a S/MIME (X.509). Používá šifrování s veřejným klíčem (asymetrická krytografie). U tohoto způsobu ochrany dat šifrujeme pomocí veřejného klíče příjemce zprávy, digitálně podepisujeme pomocí soukromého (tajného) klíče.
Komponenty GnuPG Backend – skutečný šifrovací nástroj Kleopatra – komlexní grafický správce klíčů (certifikátů) pro OpenPGP a X.509 (S/MIME) a běžné kryptografické dialogy GpgOL – doplněk pro Microsoft Outlook poskytující e-mailovou kryptografii. Podporuje servery IMAP/SMTP a MS Exchange. GpgEX – plugin pro Microsoft Explorer (šifrování souborů)
Historie Gpg4win historicky vychází z původního programu Phila Zimmermanna – Pretty Good Privacy (PGP – vcelku dobré soukromí). Později, na základě PGP, vznikl standard OpenPGP (RFC 2440, RFC 4880, RFC 9580).
Používání Praktické používání šifrování s veřejným klíčem dle standardu OpenPGP je poměrně rozsáhlé. Je to podepisování programových balíčků na systémech s operačním systémem Linux, podepisování software apod. Nejčastěji se OpenPGP používá pro bezpečnou e-mailovou komunikaci (šifrování a digitální podepisování) v e-mailových klientech na Linuxu, Windows i Androidu.
E-mailový klient Mozilla Thunderbird (multiplatformní) má podporu OpenPGP přímo v sobě, Claws Mail používá úložiště GnuPG (Kleopatra ve Windows). Na Androidu je to K-9 Mail s OpenKeychain.
Reference
Externí odkazy Server PGP klíčů – umožňuje si stáhnout veřejný klíč komunikující protistrany Koncové šigrování v e-mailovém klientu Thunderbird – šifrování s veřejným klíčem dle standardu OpenPGP Gpg4win Compendium – dokumentace k GnuPG pro Windows v pdf
Kategorie:Kryptografický software Kategorie:Svobodný bezpečnostní software Kategorie:Elektronická pošta Kategorie:Software pod licencí GPL