ESMTP (Extended Simple Mail Transfer Protocol) je rozšířením protokolu SMTP. Zavádí nové příkazy a rozšiřuje práci s protokolem SMTP. Poprvé byl definován roku 1995 v RFC 1869. Stal se součástí RFC 2821, která nahradila RFC 821.
Příkaz EHLO Oproti standardnímu SMTP spojení začínajícímu příkazem HELO začíná ESMTP spojení příkazem EHLO. Server následně odpoví v případě úspěšného navázání spojení kódem 250 a seznamem povolených příkazů. V případě selhání se použije kód 550. V případě problémů se použije některý ze standardních chybových kódů (500, 501, 502, 504 a 421), přičemž kód 500 použije starší server používající pouze protokol SMTP. Tím je umožněno doručování pošty i na ne-ESMTP servery.
Některé další příkazy 8BITMIME – umožňuje posílat zprávy v 8bitovém kódování, na rozdíl od SMTP, které používá 7 bitů SMTP-AUTH – umožňuje posílat zprávy až po předchozím přihlášení uživatele PIPELINING – umožňuje serveru posílat více příkazů během jednoho spojení SIZE – přijímající server takto sděluje, jak velkou zprávu maximálně akceptuje; odesílající server takto sděluje, jak velká je doručovaná zpráva STARTTLS – umožňuje šifrované spojení pomocí TLS
Příklad ESMTP spojení S: <čeká na spojení na portu 25> C: <navazuje spojení se serverem> S: 220 dbc.mtview.ca.us SMTP service ready C: EHLO ymir.claremont.edu S: 250-dbc.mtview.ca.us says hello S: 250-EXPN S: 250-HELP S: 250-8BITMIME S: 250-XONE S: 250 XVRB …
Poznámka: S je server, C je klient.
SMTPUTF8 Rozšíření SMTPUTF8, popsané v RFC 6531, umožňuje a definuje práci s adresami a hlavičkami obsahujícími znaky mimo US-ASCII kódování. Setkat se tak lze např. s adresami květoslav.zčeřený@example.com, δοκιμή@παράδειγμα.δοκιμή či 测试@测试.测试. Toto rozšíření podporuje např. Postfix od verze 3. Od 5. srpna 2014 zavedl podporu Gmail.A first step toward more global email
Reference
Externí odkazy RFC 1869 RFC 2821 RFC 6531
Kategorie:Aplikační protokoly IP Kategorie:Elektronická pošta
de:Simple Mail Transfer Protocol#Extended SMTP