vignette|Une vue d'ensemble de PXE L'amorçage PXE (sigle de ) permet à une station de travail de démarrer depuis le réseau en récupérant une image de système d'exploitation qui se trouve sur un serveur.
L'image ainsi récupérée peut être le système d'exploitation brut ou bien le système d'exploitation personnalisé avec des composantes logicielles (suite bureautique, utilitaires, packs de sécurité, scripts).
Une fois cette image « pré-chargée », elle peut éventuellement, en fonction des paramétrages passés à cette image sur le serveur, être installée sur la machine qui a été amorcée en PXE.
Il permet également d'installer de manière automatique et à distance des serveurs sous divers OS.
Les nouvelles technologies VDI permettent également de « er » un OS complet ainsi que ses applications associées, directement sur la station de travail sans disque dur, en bootant préalablement avec le PXE.
Pour activer le PXE, il faut auparavant le configurer dans le BIOS. L’option se trouve fréquemment dans un menu concernant la carte réseau.
L'amorce par PXE s'effectue en plusieurs étapes : recherche d'une adresse IP sur un serveur DHCP/BOOTP ainsi que du fichier à amorcer ; téléchargement du fichier à amorcer depuis un serveur Trivial FTP ; exécution du fichier à amorcer.
La taille du fichier à amorcer ne permet pas de « booter » directement un noyau Linux, par exemple, mais il faut que le logiciel à amorcer le télécharge et l'exécute lui-même.
Ce protocole est en lien avec les demandes de documentation (RFC) des standards développés par l'IETF
Documentation sur les standards d'internet de l' IETF ``` RFC #TitleDate de publicationAuteurObsolescence et information de mise à jourRFC 783The TFTP Protocol (Revision 2)Juin 1981K. Sollinsdevenu obsolète par - RFC 1350RFC 906Bootstrap Loading using TFTPJuin 1984Ross Finlayson -RFC 951Bootstrap ProtocolSeptembre 1985Bill CroftMis à jour par RFC 1395, RFC 1497, RFC 1532, RFC 1542, RFC 5494RFC 1350The TFTP Protocol (Revision 2)Juillet 1992K. SollinsMis à jour par RFC 1782, RFC 1783, RFC 1784, RFC 1785, RFC 2347, RFC 2348, RFC 2349RFC 2131Dynamic Host Configuration ProtocolMars 1997R. DromsMis à jour par RFC 3396, RFC 4361, RFC 5494, RFC 6842RFC 2348TFTP Blocksize OptionMai 1998G. Malkin -RFC 4578DHCP Options for the Intel PXENovembre 2006M. Johnston -RFC 5970DHCPv6 Options for Network BootSeptembre 2010T. Huth -RFC 7440TFTP Windowsize OptionJanvier 2015P. Masotta -
Notes et références
Voir aussi PXELinux : chargeur d'amorçage de syslinux pour PXE Clonezilla : distribution live dérivant de Debian, spécialisée dans la duplication de partitions au cluster près, à l'instar de Norton Ghost
Liens externes PXELINUX - SYSLINUX for network boot Mise en place d’un serveur de boot PXE sous Windows Le site du très pratique tftp32 « a small free multipurpose server including DHCP server and TFTP server, for Windows XP » exemple d'installation d'une distribution linux par le réseau par PXE
Pxe Pxe Catégorie:BIOS