Az ISO 639-1:2002, Codes for the representation of names of languages — Part 1: Alpha-2 code (Kódok a nyelvek neveinek megjelenítéséhez – 1. rész: Alpha-2 kód), a Nemzetközi Szabványügyi Szervezet (International Organization for Standardization; ISO) által kiadott ISO 639 nemzetközi nyelvi szabványsorozat első része, mely első kiadásában 136, a világ jelentősebb nyelveit lefedő kétbetűs nyelvkódot tartalmazott. A kódok száma később 184-re bővült.

Az ISO 639-1 elsősorban terminológiai, lexikográfiai és nyelvészeti felhasználásra készült, a kódok a nyelvek gyors és egyezményes nemzetközi jelölési módját teszik lehetővé.

A szabvány létrejötte Az 1967-ben jóváhagyott, eredeti ISO 639 szabványt részekre osztották, majd 2002-ben az ISO 639-1:2002 lett a szabvány új verziója. A kódtábla az első kiadása óta, meghatározott szempontok szerint időnként bővül, a jelenlegi utolsó hozzáadott kód a ht: Haiti kreol (2003. 02. 06.), az utolsó változtatás a bh, bih: Bihári nyelvek (2009. 09. 01.). Az eredeti 136 kód helyett jelenleg 184-et tartalmaz.

A szabvány használatát az 1995 márciusában az RFC 1766 által bevezetett, majd 2001. januárjától az RFC 3066-ban és 2006. szeptemberétől az RFC 4646-ban folytatódó IETF nyelvi attribútum ösztönözte. A jelenlegi verzió 2009. szeptembere óta az RFC 5646. Az ISO 639-1 kódok regisztrációszolgáltatója az Infoterm (International Information Center for Terminology).

A kódtábla bővítése csak speciális szabályok szerint lehetséges. Amennyiben az adott önálló nyelvre már létezik ISO 639-2 kód, új 639-1 kód nem kerül kialakításra, ezért azokban a rendszerekben, melyek mind a 639-1, mind a 639-2 kódokat használják, az előbbi előnyben részesítésével, nincs szükség rá, hogy a létező kódokat megváltoztassák. Amennyiben nyelvcsoportot (kollektív nyelvet) jelölő 639-2 kód van használatban, az bizonyos nyelvek esetében felülírható új 639-1 kóddal. Makronyelvek kezelésére a szabvány nem tartalmaz leírást, ez az ISO 639-3-ban szerepel.

A kódok képzése A rövidítések képzése alapesetben a nyelvek saját elnevezéseiből történik, a nem latin vagy cirill írású nyelvek esetében azonban többnyire az angol elnevezésükből. A kódok első betűi mindig a (vagy saját vagy angol) nyelvnév kezdőbetűivel azonosak.

Példák saját névből képzett kódokra: a kód a nyelvnév első két betűje: angol – en (English), német – de (Deutsch), spanyol – es (español) ha az adott kód már foglalt, akkor a második betű a nyelvnév valamelyik jellegzetes betűje: örmény – hy (հայերէն, hayeren), holland – nl (Nederlands), eszperantó – eo (esperanto), albán – sq (shqip) ha ez is foglalt, akkor a kódokban még nem szereplő tetszőleges másik betű (ritkán): szárd – sc (Sardinian; a saját név sardu; sa: szanszkrit, sr: szerb, sd: szindhi, si: szingaléz, sn: sona, su: szundai) Példák angol névből képzett kódokra: japán – ja (Japanese; a saját név 日本語 Nihongo) odzsibva – oj (Ojibwa; a saját név ᐊᓂᔑᓈᐯᒧᐎᓐ anishinaabemowin){| class="wikitable collapsible collapsed" align="center" ! colspan="27"|Az ISO 639-1 kódjai |- |colspan="27"|dőlttel a szabvány első kiadása után hozzáadott kódok, áthúzott dőlttel a törölt kódok |- ! !!-a!!-b!!-c!!-d!!-e!!-f!!-g!!-h!!-i!!-j!!-k!!-l!!-m!!-n!!-o!!-p!!-q!!-r!!-s!!-t!!-u!!-v!!-w!!-x!!-y!!-z |- |a-||aa ||ab || || ||ae ||af || || || || ||ak || ||am ||an || || || ||ar ||as || || ||av || || ||ay ||az |- |b-||ba || || || ||be || ||bg ||bh ||bi || || || ||bm ||bn ||bo || || ||br ||bs || || || || || || || |- |c-||ca || || || ||ce || || ||ch || || || || || || ||co || || ||cr ||cs || ||cu ||cv || || ||cy || |- |d-||da || || || ||de || || || || || || || || || || || || || || || || ||dv || || || ||dz |- |e-|| || || || ||ee || || || || || || ||el || ||en ||eo || || || ||es ||et ||eu || || || || || |- |f-||fa || || || || ||ff || || ||fi ||fj || || || || ||fo || || ||fr || || || || || || ||fy || |- |g-||ga || || ||gd || || || || || || || ||gl || ||gn || || || || || || ||gu ||gv || || || || |- |h-||ha || || || ||he || || || ||hi || || || || || ||ho || || ||hr || ||ht ||hu || || || ||hy ||hz |- |i-||ia || || ||id ||ie || ||ig || ||ii || ||ik || ||in || ||io || || || ||is ||it ||iu || ||iw || || || |- |j-||ja || || || || || || || ||ji || || || || || || || || || || || || ||jv ||jw || || || |- |k-||ka || || || || || ||kg || ||ki ||kj ||kk ||kl ||km ||kn ||ko || || ||kr ||ks || ||ku ||kv ||kw || ||ky || |- |l-||la ||lb || || || || ||lg || ||li || || || || ||ln ||lo || || || || ||lt ||lu ||lv || || || || |- |m-|| || || || || || ||mg ||mh ||mi || ||mk ||ml || ||mn ||mo || || ||mr ||ms ||mt || || || || ||my || |- |n-||na ||nb || ||nd ||ne || ||ng || || || || ||nl || ||nn ||no || || ||nr || || || ||nv || || ||ny || |- |o-|| || ||oc || || || || || || ||oj || || ||om || || || || ||or ||os || || || || || || || |- |p-||pa || || || || || || || ||pi || || ||pl || || || || || || ||ps ||pt || || || || || || |- |q-|| || || || || || || || || || || || || || || || || || || || ||qu || || || || || |- |r-|| || || || || || || || || || || || ||rm ||rn ||ro || || || || || ||ru || ||rw || || || |- |s-||sa || ||sc ||sd ||se || ||sg ||sh ||si || ||sk ||sl ||sm ||sn ||so || ||sq ||sr ||ss ||st ||su ||sv ||sw || || || |- |t-||ta || || || ||te || ||tg ||th ||ti || ||tk ||tl || ||tn ||to || || ||tr ||ts ||tt || || ||tw || ||ty || |- |u-|| || || || || || ||ug || || || ||uk || || || || || || ||ur || || || || || || || ||uz |- |v-|| || || || ||ve || || || ||vi || || || || || ||vo || || || || || || || || || || || |- |w-||wa || || || || || || || || || || || || || ||wo || || || || || || || || || || || |- |x-|| || || || || || || ||xh || || || || || || || || || || || || || || || || || || |- |y-|| || || || || || || || ||yi || || || || || ||yo || || || || || || || || || || || |- |z-||za || || || || || || ||zh || || || || || || || || || || || || ||zu || || || || ||

Az ISO 639-1 szabvány változásai Az ISO 639-1 szabványban, annak első kiadása óta, számos változás történt. Az alábbi táblázat a kódtáblában 2010. október 18-ig bekövetekezett valamennyi változást tartalmazza az ISO 639-2 Registration Authority alapján ("Additions/Changes to ISO 639 Codes as published in ISO 639-1:1988 and ISO 639-2:1998.").

A táblázathoz: A változások típusai: K+ = új kód (és egyben új nyelv) hozzáadása, K- = kód visszavonása (a visszavont kód []-ben, előtte "-" jellel, pl. [-mo]), K± = kódcsere (régi kód visszavonása, új kód hozzáadása); N+ = névváltozat hozzáadása, N- = névváltozat eltávolítása, N± = névcsere (régi név helyett új).

Az ISO 639-1 kód- és névváltozásaiISO-kód Név Változtatás 639-1 639-2 magyar angol dátuma típusaae ave avesztai Avestan 2000. 02. 18. K+ ak aka akan Akan 1999. 08. 16. K+ an arg aragóniai Aragonese 2002. 12. 23. K+ av ava avar Avaric 1999. 08. 16. K+ bh bih bihári nyelvek Bihari languages 2009. 09. 01. N± bm bam bambara Bambara 2000. 02. 18. K+ bs bos bosnyák Bosnian 2000. 02. 18. K+ ce che csecsen Chechen 2000. 02. 18. K+ ch cha csamorro Chamorro 2000. 02. 18. K+ cr cre krí Cree 1999. 08. 16. K+ cu chu óegyházi szláv Church Slavic; Old Slavonic; ChurchSlavonic; Old Bulgarian; Old Church Slavonic 2000. 02. 18. K+ cv chv csuvas Chuvash 2000. 02. 18. K+ dv div maldív Divehi; Dhivehi; Maldivian 1999. 08. 16. K+ dv div maldív Divehi; Dhivehi; Maldivian 2006. 06. 07. N+ee ewe eve Ewe 1999. 08. 16. K+ ff ful ful Fulah 1999. 08. 16. K+ fy fry fríz (nyugati) Western Frisian 2005. 11. 16. N±gl glg galiciai Galician 2005. 07. 25. N±gv glv manx Manx 1998. 08. 10. K+ he [-iw] heb héber (modern) Hebrew 1989. 03. 11. K± ho hmo hiri motu Hiri Motu 2000. 02. 18. K+ ht hat haiti kreol Haitian; Haitian Creole 2003. 02. 26. K+ hz her herero Herero 2000. 02. 18. K+ id [-in] ind indonéz Indonesian 1989. 03. 11. K± ie ile interlingue Interlingue; Occidental 2007. 10. 18. N+ ig ibo igbo Igbo 1999. 08. 16. K+ ii iii nuoszu (szecsuáni ji) Sichuan Yi; Nuosu 2002. 10. 14. K+ ii iii nuoszu (szecsuáni ji) Sichuan Yi; Nuosu 2007. 10. 18. N+ io ido ido Ido 2002. 01. 15. K+ iu iku inuktitut Inuktitut 1989. 03. 11. K+ jv [-jw] jav [-jaw] jávai Javanese 2001. 08. 13. K± kg kon kikongo Kongo 1999. 08. 16. K+ ki kik kikuju Kikuyu; Gikuyu 2000. 02. 18. K+ kj kua kvanyama Kuanyama; Kwanyama 2000. 02. 18. K+ km khm khmer (központi) Central Khmer 2006. 10. 27. N±kr kau kanuri Kanuri 1999. 08. 16. K+ kv kom komi Komi 2000. 02. 18. K+ kw cor korni Cornish 1998. 08. 10. K+ ky kir kirgiz Kirghiz; Kyrgyz 2006. 10. 02. N+lb ltz luxemburgi Luxembourgish; Letzeburgesch 1998. 08. 10. K+ lg lug luganda Ganda 1999. 08. 16. K+ li lim limburgi Limburgan; Limburger; Limburgish 2002. 08. 02. K+ lu lub luba-katanga Luba-Katanga 1999. 08. 16. K+ mh mah Marshall-szigeteki Marshallese 2000. 02. 18. K+ mo[–] mol[–] moldáv Moldavian; Moldovan 2008. 06. 26. N+ mo[-mo] mol[-mol] moldáv Moldavian2008. 11. 03. K-nb nob norvég bokmål Bokmål, Norwegian; Norwegian Bokmål 2000. 02. 18. K+ nd nd északi ndebele Ndebele, North; North Ndebele 2000. 08. 14. N± ng ndo ndonga Ndonga 2000. 02. 18. K+ nn nno norvég nynorsk Norwegian Nynorsk; Nynorsk, Norwegian 2000. 02. 18. K+ nr nbl déli ndebele Ndebele, South; South Ndebele 2000. 08. 14. K+ nv nav navahó Navajo; Navaho 2000. 02. 18. K+ ny nya cseva Chichewa; Chewa; Nyanja 2000. 02. 18. K+ ny nya cseva Chichewa; Chewa; Nyanja 2000. 02. 18. N+ oc oci okcitán Occitan (post 1500) 2008. 07. 08. N-oj oji odzsibva Ojibwa 1999. 08. 16. K+ os oss oszét Ossetian; Ossetic 2000. 02. 18. K+ os oss oszét Ossetian; Ossetic 2000. 02. 18. N+pi pli páli Pali 2000. 02. 18. K+ ps pus pastu Pushto; Pashto 2007. 12. 17. N+ rm roh romans Romansh 2006. 10. 25. N±sc srd szárd (szardíniai) Sardinian 2000. 02. 18. K+ se sme északi számi Northern Sami 2000. 02. 18. K+ sh[-sh] – szerbhorvát Serbo-Croatian 2000. 02. 18.K- si sin szingaléz Sinhala; Sinhalese 2004. 10. 19. N+ty tah tahiti Tahitian 2000. 02. 18. K+ ug uig ujgur Uighur; Uyghur 1989. 03. 11. K+ ve ven venda Venda 1999. 08. 16. K+ wa win vallon Walloon 2002. 01. 29. K+yi [-ji] yid jiddis Yiddish 1989. 03. 11. K± za zha zhuang Zhuang; Chuang 1989. 03. 11. K+Megjegyzések a táblázathozNévváltozások (N+, N-, N±): Kódváltozások (K+, K-, K±): ; ;

Jegyzetek

Források ISO 639-1

ISO 639-2

ISO 639-2/RA ISO 639-2/RA Codes for the Representation of Names of Languages Part 2: Alpha-3 Code – – A hivatalos és frissülő 639-1 és 639-2 kódlista.

– A 639-1 és 639-2 kódváltozásainak teljes és frissülő listája.

RFC Alvestrand, Harald Tveit: "Tags for the Identification of Languages", RFC 1766, UNINETT, March 1995. Alvestrand, Harald Tveit: "Tags for the Identification of Languages", BCP 47, RFC 3066, Cisco Systems, January 2001. Phillips, Addison (Ed.) – Davis, Mark (Ed.): "Tags for Identifying Languages", BCP 47, RFC 4646, Yahoo! Inc., Google, September 2006. Phillips, Addison (Ed.) – Davis, Mark (Ed.): "Matching of Language Tags", BCP 47, RFC 4647, Yahoo! Inc., Google, September 2006. Phillips, Addison (Ed.) – Davis, Mark (Ed.): "Tags for Identifying Languages", BCP 47, RFC 5646, Lab126, Google, September 2009.

További információk

Kapcsolódó szócikkek IETF IETF nyelvi attribútum RFC

Kategória:ISO-szabványok

la:ISO 639#ISO 639-1 nl:ISO 639#ISO 639-1