frameless|right NFS (acrônimo para Network File System) é um sistema de arquivos distribuídos desenvolvido inicialmente pela Sun Microsystems, Inc., a fim de compartilhar arquivos e diretórios entre computadores conectados em rede, formando assim um diretório virtual. O protocolo Network File System é especificado nas seguintes RFCs: RFC 1094, RFC 1813 e RFC 7931 (que atualiza a RFC 7530, que tornou obsoleta a RFC 3530).

Finalidade O cliente NFS tem por finalidade tornar o acesso remoto transparente para o usuário do computador, e esta interface cliente e servidor, executada pelo NFS através dos protocolos Cliente-Servidor, fica bem definida quando o usuário, ao chamar um arquivo/diretório no servidor, lhe parece estar acessando localmente, sendo que está trabalhando com arquivos remotamente. Existe uma certa semelhança desse protocolo com o CIFS pois os dois permitem o compartilhamento de recursos entre sistemas, por meio de uma rede de computadores, com arquitetura cliente-servidor, e quaisquer que sejam suas plataformas de hardware e software.

Utilização Um exemplo da utilização do NFS é a disponibilização das áreas de trabalho dos usuários em toda a rede e, quando este efetua o login, seu diretório de trabalho pode ser acessado via NFS. Supondo que o usuário mude de estação de trabalho, o seu diretório pode ser disponibilizado novamente nesta estação e sem que nenhuma configuração adicional seja realizada.

Sua interface é pública e muito utilizada para o compartilhamento de leituras e organizações acadêmicas, pelas vantagens de, entre outras: transparência; unificação de comandos; redução de espaço local; independência de sistemas operacionais e hardware.

Para um sistema cliente-Servidor, o cliente pode sempre que logar na máquina "importar" automaticamente os diretórios e arquivos que o mesmo criou na sua área pessoal, por exemplo (para implementar esse sistema de importacão de arquivo associado a um usuário em específico é necessário ter configurado um Sistema com LDAP ou NIS, além do NFS).

Implementação Para que os clientes possam acessar o servidor NFS é necessário que os seguintes daemons estejam executando:

nfsd - daemon NFS, que atende requisições dos clientes NFS. mountd - daemon de montagem NFS, que executa as solicitações que o nfsd lhe passa. portmap - daemon portmapper, permite que clientes NFS descubram qual porta o servidor NFS está utilizando.

Ver também CIFS - Common Internet File System Sistema de arquivos virtual Samba (servidor) NIS

Ligações externas

RFC 7931 - NFS Version 4 Protocol Specification RFC 1813 - NFS Version 3 Protocol Specification RFC 1094 - NFS Version 2 Protocol Specification Sistemas de Informação Distribuídos/Infraestrutura (em português)

Categoria:Protocolos da Internet Categoria:Redes de computadores Categoria:Computação distribuída Categoria:Programas Unix