O Roteamento Interdomínio Sem Classes (CIDR) é um método de alocação de endereços do Protocolo de Internet (IP) para roteamento do Protocolo de Internet (IP). A Força-Tarefa de Engenharia da Internet (IETF) introduziu o Roteamento Interdomínio Sem Classes (CIDR) em 1993 para substituir a arquitetura de endereçamento de rede com classes anterior na Internet. Seu objetivo era desacelerar o crescimento das tabelas de roteamento em roteadores na Internet e ajudar a retardar o rápido esgotamento dos endereços da versão 4 do Protocolo de Internet (IPv4).

Os endereços do Protocolo de Internet (IP) são descritos como compostos por dois grupos de bits: os bits mais significativos são o prefixo de rede, que identifica uma rede ou sub-rede inteira, e o conjunto menos significativo forma o identificador de host, que especifica uma interface específica de um host nessa rede. Essa divisão é usada como base para o roteamento de tráfego entre redes do Protocolo de Internet (IP) e para políticas de alocação de endereços.

Enquanto o design de rede com classes para a versão 4 do Protocolo de Internet (IPv4) dimensionava o prefixo de rede como um ou mais grupos de oito bits, resultando em blocos de endereços de Classe A, B ou C, sob o roteamento entre domínios sem classes (CIDR) o espaço de endereçamento é alocado para provedores de serviços de Internet e usuários finais em qualquer limite de bits de endereço. Na versão 6 do Protocolo de Internet (IPv6), no entanto, o identificador de interface tem um tamanho fixo de 64 bits por convenção, e sub-redes menores nunca são alocadas aos usuários finais.

O Roteamento Interdomínio Sem Classes (CIDR) é baseado no mascaramento de sub-redes de comprimento variável (VLSM), no qual os prefixos de rede têm comprimento variável (diferentemente dos prefixos de comprimento fixo dos projetos de redes com classes anterior). O principal benefício disso é que ele concede um controle mais preciso dos tamanhos das sub-redes alocadas para as organizações, desacelerando assim o esgotamento dos endereços da versão 4 do Protocolo de Internet (IPv4) ao alocar sub-redes maiores do que o necessário. O roteamento entre domínios sem classes (CIDR) deu origem a uma nova forma de escrever os endereços do Protocolo de Internet (IP) conhecida como notação do roteamento entre domínios sem classes (CIDR), na qual os endereços Protocolo de Internet (IP) são seguidos por sufixos indicando o número de bits dos prefixos. Alguns exemplos da notação do roteamento entre domínios sem classes (CIDR) são os endereços para a versão 4 do Protocolo de Internet (IPv4) e para a versão 6 do Protocolo de Internet (IPv6). Os blocos de endereços com prefixos contíguos podem ser agregados como super-redes, reduzindo o número de entradas nas tabelas de roteamento globais.

Contexto Cada endereço do Protocolo de Internet (IP) consiste em um prefixo de rede seguido por um identificador de host. Na arquitetura de rede com classes da versão 4 do Protocolo de Internet (IPv4), os três bits mais significativos do endereço do Protocolo de Internet (IP) de 32 bits definiam o tamanho do prefixo de rede para redes unicast e determinavam a classe de rede A, B ou C.

ClasseBits mais significativosComprimentodos prefixos de redes(bits)Comprimentodos identificadores de hosts(bits)Intervalo de endereçosA08240.0.0.0 – 126.255.255.255Loopback 0 8 24 127.0.0.0 – 127.255.255.255B101616128.0.0.0 – 191.255.255.255C110248192.0.0.0 – 223.255.255.255D(multicast)1110224.0.0.0 – 239.255.255.255E(reservado)1111240.0.0.0 – 255.255.255.255

A vantagem desse sistema é que o prefixo de rede pode ser determinado para qualquer endereço do Protocolo de Internet (IP) sem nenhuma informação adicional. A desvantagem é que as redes geralmente eram muito grandes ou muito pequenas para a maioria das organizações usarem, porque apenas três tamanhos estavam disponíveis. O menor bloco de alocação e roteamento continha 28 = 256 endereços, maior do que o necessário para redes pessoais ou departamentais, mas muito pequeno para a maioria das empresas. O próximo bloco maior continha 216 = 65.536 endereços, grande demais para ser usado eficientemente mesmo por grandes organizações. Mas para usuários de rede que precisavam de mais de 65.536 endereços, o único outro tamanho (224) fornecia muitos, mais de 16 milhões. Isso levou a ineficiências no uso de endereços, bem como ineficiências no roteamento, porque exigia um grande número de redes classe C alocadas com anúncios de rota individuais, sendo geograficamente dispersas com pouca oportunidade para agregação de rotas.

Uma década após a invenção do Sistema de Nomes de Domínios (DNS), o método de rede com classes foi considerado como não sendo escalável. Isso levou ao desenvolvimento de sub-redes e do Roteamento Interdomínio Sem Classes (CIDR). As distinções de classe, anteriormente significativas, baseadas nos bits de endereço mais significativos foram abandonadas e o novo sistema foi descrito como "sem classes", em contraste com o sistema antigo, que ficou conhecido como "com classes". Os protocolos de roteamento foram revisados para transportar não apenas endereços do Protocolo de Internet (IP), mas também suas máscaras de sub-rede. A implementação do Roteamento Interdomínio Sem Classes (CIDR) exigiu que cada host e roteador na Internet fosse reprogramado em pequenas etapas — um feito nada desprezível em um momento em que a Internet estava entrando em um período de rápido crescimento. Em 1993, a Força-Tarefa de Engenharia da Internet (IETF) publicou um novo conjunto de padrões, RFC 1518 e RFC 1519, para definir esse novo princípio para alocação de blocos de endereços do Protocolo de Internet (IP) e roteamento de pacotes da versão 4 do Protocolo de Internet (IPv4). Uma versão atualizada, RFC 4632, foi publicada em 2006.

Após um período de experimentação com diversas alternativas, o Roteamento Interdomínio Sem Classes (CIDR( foi baseado no mascaramento de sub-rede de comprimento variável (VLSM), que permite que cada rede seja dividida em sub-redes de vários tamanhos de potência de dois, para que cada sub-rede possa ser dimensionada adequadamente para as necessidades locais. Máscaras de sub-rede de comprimento variável (VLSMs) foram mencionadas como uma alternativa na RFC 950. Técnicas para agrupar endereços para operações comuns foram baseadas no conceito de endereçamento de cluster, proposto pela primeira vez por Carl-Herbert Rokitansky.Carl-Herbert Rokitansky, "Internet Cluster Addressing Scheme and its Application to Public Data Networks", Proc. 9th International Conference on Computer Communication (ICCC' 88), pp. 482–491, Tel Aviv, Israel, outubro/novembro de 1988Cluster Addressing and CIDR nos arquivos de e-mail da IETF

Notação do CIDR A notação do Roteamento Interdomínio Sem Classes (CIDR) é uma representação compacta de um endereço do Protocolo de Internet (IP) e sua máscara de rede associada. A notação foi inventada por Phil Karn na década de 1980. A notação do Roteamento Interdomínio Sem Classes (CIDR) especifica um endereço do Protocolo de Internet (IP), um caractere de barra ⟨/⟩ e um número decimal. O número decimal é a contagem de bits 1 iniciais consecutivos (da esquerda para a direita) na máscara de rede. Cada bit 1 denota um bit do intervalo de endereços que deve permanecer idêntico ao endereço do Protocolo de Internet (IP) fornecido. O endereço do Protocolo de Internet (IP) na notação do Roteamento Interdomínio Sem Classes (CIDR) é sempre representado de acordo com os padrões para a versão 4 do Protocolo de Internet (IPv4) ou para a versão 6 do Protocolo de Internet (IPv6).

O endereço pode denotar um endereço de interface específico (incluindo um identificador de host, como ), ou pode ser o endereço inicial de uma rede inteira (usando um identificador de host 0, como em ou seu equivalente ). A notação do Roteamento Interdomínio Sem Classes (CIDR) pode até ser usada sem nenhum endereço do Protocolo de Internet (IP), por exemplo, ao se referir a um como uma descrição genérica de uma rede da versão 4 do Protocolo de Internet (IPv4) que possui um prefixo de 24 bits e números de host de 8 bits.

Por exemplo: representa o endereço da versão 4 do Protocolo de Internet (IPv4) e seu prefixo de rede associado , ou equivalentemente, sua máscara de sub-rede , que tem 24 bits 1 iniciais. o bloco da versão 4 do Protocolo de Internet (IPv4) representa os 1.024 endereços de a da versão 4 do Protocolo de Internet (IPv4). o bloco da versão 6 do Protocolo de Internet (IPv6) representa o bloco de endereços de a da versão 6 do Protocolo de Internet (IPv6). representa o endereço de retorno da versão 6 do Protocolo de Internet (IPv6). Seu comprimento de prefixo é 128, que é o número de bits do endereço.

Na versão 4 do Protocolo de Internet (IPv4), a notação do Roteamento Interdomínio Sem Classes (CIDR) passou a ser amplamente utilizada somente após a implementação do método, que foi documentado usando a especificação de máscara de sub-rede decimal com pontos após a barra, por exemplo, . Descrever a largura do prefixo de rede como um único número () tornou-se mais fácil para os administradores de rede conceituarem e calcularem. Ela foi gradualmente incorporada em documentos de padrões posteriores e em interfaces de configuração de rede.

O número de endereços de uma rede pode ser calculado como 2 comprimento do endereço − comprimento do prefixo, onde o "comprimento do endereço" é 128 para a versão 6 do Protocolo de Internet (IPv6) e 32 para a versão 4 do Protocolo de Internet (IPv4). Por exemplo, na versão 4 do Protocolo de Internet (IPv4), o comprimento do prefixo resulta em: 232 − 29 = 23 = 8 endereços.

Máscaras de sub-redes Uma máscara de sub-rede é uma máscara de bits que codifica o comprimento do prefixo associado a um endereço ou rede da versão 4 do Protocolo de interfaces (IPv4) em notação de quatro pontos: 32 bits, começando com um número de uns igual ao comprimento do prefixo, terminando com zeros, e codificado em formato decimal com pontos de quatro partes: . Uma máscara de sub-rede codifica as mesmas informações que um comprimento de prefixo, mas é anterior ao advento do Roteamento Interdomínio Sem Classes (CIDR). Na notação do Roteamento Interdomínio Sem Classes (CIDR), os bits de prefixo são sempre contíguos. Máscaras de sub-rede eram permitidas pela RFC 950 para especificar bits que não são contíguos até que a RFC 4632 estabeleceu que a máscara deve consistir apenas de uns contíguos, se houver, nos bits mais significativos e zeros contíguos, se houver, nos bits menos significativos. Dada essa restrição, uma máscara de sub-rede e a notação do Roteamento Interdomínio Sem Classes (CIDR) têm exatamente a mesma função.

Blocos do CIDR