MPEG-4 Part 3 ou MPEG-4 Audio (formalmente ISO/IEC 14496-3) é a terceira parte do padrão internacional ISO/IEC MPEG-4 desenvolvido pelo Moving Picture Experts Group. Ele especifica métodos de codificação de áudio. A primeira versão do ISO/IEC 14496-3 foi publicada em 1999.
O MPEG-4 Parte 3 consiste em uma variedade de tecnologias de codificação de áudio – desde codificação de fala Compressão com perda de dadoscom perdas (HVXC, CELP), codificação geral de áudio (AAC, TwinVQ, BSAC), compressão de áudio sem perdas (MPEG-4 SLS, Audio Lossless Coding, MPEG-4 DST), uma interface de texto para fala (TTSI), áudio estruturado (usando SAOL, SASL, MIDI) e muitas técnicas adicionais de síntese e codificação de áudio.
O MPEG-4 Audio não tem como alvo uma única aplicação, como telefonia em tempo real ou compressão de áudio de alta qualidade. Ele se aplica a todas as aplicações que exigem o uso de compressão, síntese, manipulação ou reprodução avançadas de som. O MPEG-4 Audio é um novo tipo de padrão de áudio que integra vários tipos diferentes de codificação de áudio: som natural e som sintético, entrega de baixa taxa de bits e entrega de alta qualidade, fala e música, trilhas sonoras complexas e simples, conteúdo tradicional e conteúdo interativo.
Versões +Versões e edições de áudio MPEG-4 Edição Data de lançamento Última alteração Padrão Descrição Primeira edição 1999 2001 ISO/IEC 14496-3:1999 também conhecido como "MPEG-4 Audio Version 1" 2000 ISO/IEC 14496-3:1999/Amd 1:2000 também conhecido como "MPEG-4 Audio Version 2", uma Emenda (Amendment) à primeira edição Segunda edição 2001 2005 ISO/IEC 14496-3:2001 Terceira edição 2005 2008 ISO/IEC 14496-3:2005 Quarta edição 2009 2015 e em desenvolvimento ISO/IEC 14496-3:2009 Quinta edição 2019 ISO/IEC 14496-3:2019 Versão atual
Subpartes O MPEG-4 Parte 3 contém as seguintes subpartes: Subparte 1: Principal (lista de tipos de objetos de áudio, perfis, níveis, interface para ISO/IEC 14496-1, fluxo de transporte de áudio MPEG-4, etc.) Subparte 2: Codificação de fala – HVXC (Harmonic Vector eXcitation Coding) Subparte 3: Codificação de fala – CELP (Code Excited Linear Prediction) Subparte 4: Codificação geral de áudio (GA) (codificação de tempo/frequência) – AAC, TwinVQ, BSAC Subparte 5: Áudio Estruturado (SA) Subparte 6: Interface de texto para fala (TTSI) Subparte 7: Codificação de áudio paramétrica – HILN (Harmônico e linha individual mais ruído) Subparte 8: Descrição técnica da codificação paramétrica para áudio de alta qualidade (SSC, Parametric Stereo) Subparte 9: Áudio MPEG-1/MPEG-2 em MPEG-4 Subparte 10: Descrição técnica da codificação sem perdas de áudio sobreamostrado (MPEG-4 DST – Direct Stream Transfer) Subparte 11: Codificação sem perdas de áudio (ALS) Subparte 12: Codificação sem perdas escalável (SLS)
Tipos de objetos de áudio MPEG-4 O MPEG-4 Audio inclui um sistema para lidar com um grupo diverso de formatos de áudio de maneira uniforme. Cada formato recebe um Tipo de Objeto de Áudio exclusivo para representá-lo. O Tipo de Objeto é usado para distinguir entre diferentes métodos de codificação. Ele determina diretamente o subconjunto de ferramentas MPEG-4 necessário para decodificar um objeto específico. Os perfis MPEG-4 são baseados nos tipos de objeto e cada perfil suporta uma lista diferente de tipos de objeto.
+Tipos de objetos de áudio MPEG-4 ID do tipo de objeto Tipos de objeto de áudio Primeira data de lançamento público Descrição 1 AAC Principal (AAC Main) 1999 contém AAC LC 2 AAC LC (Baixa Complexidade) (Low Complexity) 1999 Usado no "Perfil AAC". O tipo de objeto de áudio MPEG-4 AAC LC é baseado no perfil de baixa complexidade (LC) MPEG-2 Parte 7 combinado com Substituição de ruído perceptual (PNS) (definido em MPEG-4 Parte 3 Subparte 4). 3 AAC SSR (Taxa de Amostragem Escalável) (Scalable Sample Rate) 1999 O tipo de objeto de áudio MPEG-4 AAC SSR é baseado no perfil de taxa de amostragem escalável (SSR) MPEG-2 Parte 7 combinado com substituição de ruído perceptual (PNS) (definido em MPEG-4 Parte 3 Subparte 4). 4 AAC LTP (Long Term Prediction) 1999 contém AAC LC 5 SBR (Spectral Band Replication) 2003 usado com AAC LC no "Perfil AAC de alta eficiência" ("High Efficiency AAC Profile") (HE-AAC v1) 6 AAC Escalável (AAC Scalable) 1999 7 TwinVQ 1999 codificação de áudio em taxas de bits muito baixas 8 CELP (Code Excited Linear Prediction) 1999 codificação de fala 9 HVXC (Harmonic Vector eXcitation Coding) 1999 codificação de fala 10 (Reservado) 11 (Reservado) 12 TTSI (Interface de Síntese de fala) 1999 13 Síntese principal (Main synthesis) 1999 contém sample-based synthesis 'wavetable' e síntese algorítmica e efeitos de áudio (Algorithmic Synthesis and Audio Effects) 14 sample-based synthesis 'wavetable' 1999 baseado em SoundFont e DownLoadable Sounds, contém General MIDI 15 General MIDI 1999 16 Síntese Algorítmica e Efeitos de Áudio (Algorithmic Synthesis and Audio Effects) 1999 17 ER AAC LC 2000 Resiliente a erros (Error Resilient) 18 (Reservado) 19 ER AAC LTP 2000 Resiliente a erros (Error Resilient) 20 ER AAC Escalável (ER AAC Scalable) 2000 Resiliente a erros (Error Resilient) 21 ER TwinVQ 2000 Resiliente a erros (Error Resilient) 22 ER BSAC (codificação aritmética em fatias de bits) (Bit-Sliced Arithmetic Coding) 2000 Também é conhecido como "Fine Granule Audio" ou ferramenta de escalabilidade de grão fino. É usado em combinação com as ferramentas de codificação AAC e substitui a codificação silenciosa e a formatação de fluxo de bits do codificador MPEG-4 Versão 1 GA. Resiliente a erros 23 ER AAC LD (baixo atraso) (Low Delay) 2000 Resiliente a erros, usado com CELP, ER CELP, HVXC, ER HVXC e TTSI no "Perfil de baixo atraso" ("Low Delay Profile"), (comumente usado para aplicações de conversação em tempo real) 24 ER CELP 2000 Resiliente a erros (Error Resilient) 25 ER HVXC 2000 Resiliente a erros (Error Resilient) 26 ER HILN (Linhas Harmônicas e Individuais mais Ruído) (Harmonic and Individual Lines plus Noise) 2000 Resiliente a erros (Error Resilient) 27 ER Parametric 2000 Resiliente a erros (Error Resilient) 28 SSC (codificação sinusoidal) (SinuSoidal Coding) 2004 29 PS (Parametric Stereo) 2004 e 2006 usado com AAC LC e SBR no "HE-AAC v2 Profile" ("HE-AAC v2 Profile"). A ferramenta de codificação PS foi definida em 2004 e o Tipo de Objeto definido em 2006. 30 MPEG Surround 2007 também conhecido como MPEG Spatial Audio Coding (SAC), é um tipo de codificação de áudio espacial (MPEG Surround também foi definido na ISO/IEC 23003-1 em 2007) 31 (ESCAPE) 32 MPEG-1/2 Layer-1 2005 33 MPEG-1/2 Layer-2 2005 34 MPEG-1/2 Layer-3 2005 também conhecido como "MP3onMP4" 35 DST (Direct Stream Transfer) 2005 codificação de áudio sem perdas, usada em Super Audio CD 36 ALS (Audio Lossless Coding) 2006 codificação de áudio sem perdas 37 SLS (Scalable Lossless Coding) 2006 codificação de áudio de duas camadas com camada sem perdas e núcleo/camada de áudio geral com perdas (por exemplo, AAC) 38 SLS não essencial (non-core) 2006 codificação de áudio sem perdas sem núcleo/camada de áudio geral com perdas (por exemplo, AAC) 39 ER AAC ELD (Enhanced Low Delay) 2008 Resiliente a erros (Error Resilient) 40 SMR (Representação Musical Simbólica) Simples (Symbolic Music Representation) (Simple) 2008 nota: Symbolic Music Representation também é o padrão MPEG-4 Part 23(ISO/IEC 14496-23:2008) 41 SMR Principal (SMR Main) 2008 42 USAC (Unified Speech and Audio Coding) 2012 A codificação unificada de fala e áudio é definida na Parte 3 do MPEG-D (ISO/IEC 23003-3:2012) 43 SAOC (Spatial Audio Object Coding) 2010 nota: A codificação de objetos de áudio espacial também é o padrão MPEG-D Parte 2(ISO/IEC 23003-2:2010) 44 LD MPEG Surround 2010 Este tipo de objeto transmite informações secundárias de codificação surround MPEG de baixo atraso (que foram definidas na Parte 2 do MPEG-D – ISO/IEC 23003-2) na estrutura de áudio MPEG-4. 45 SAOC-DE 2013 Melhoria do diálogo de codificação de objeto de áudio espacial 46 Sincronização de áudio (Audio Sync) 2015 A ferramenta de sincronização de áudio oferece a capacidade de sincronizar vários conteúdos em vários dispositivos.
Perfis de Áudio
O padrão de áudio MPEG-4 define vários perfis. Esses perfis são baseados nos tipos de objetos e cada perfil suporta uma lista diferente de tipos de objetos. Cada perfil também pode ter vários níveis, o que limita alguns parâmetros das ferramentas presentes em um perfil. Esses parâmetros geralmente são a taxa de amostragem e o número de canais de áudio decodificados ao mesmo tempo.
+Perfis de áudio MPEG-4 Perfis de Áudio Tipos de objetos de áudio Primeira data de lançamento público Perfil AAC (AAC Profile) AAC LC 2003 Perfil AAC de alta eficiência (High Efficiency AAC Profile) AAC LC, SBR 2003 Perfil HE-AAC v2 (HE-AAC v2 Profile) AAC LC, SBR, PS 2006 Perfil de áudio principal (Main Audio Profile) AAC Main, AAC LC, AAC SSR, AAC LTP, AAC Scalable, TwinVQ, CELP, HVXC, TTSI, Main synthesis 1999 Perfil de áudio escalável (Scalable Audio Profile) AAC LC, AAC LTP, AAC Scalable, TwinVQ, CELP, HVXC, TTSI 1999 Perfil de áudio de fala (Speech Audio Profile) CELP, HVXC, TTSI 1999 Perfil de Áudio Sintético (Synthetic Audio Profile) TTSI, Síntese principal (Main synthesis) 1999 Perfil de áudio de alta qualidade (High Quality Audio Profile) AAC LC, AAC LTP, AAC Scalable, CELP, ER AAC LC, ER AAC LTP, ER AAC Scalable, ER CELP 2000 Perfil de áudio de baixo atraso (Low Delay Audio Profile) CELP, HVXC, TTSI, ER AAC LD, ER CELP, ER HVXC 2000 Perfil de áudio natural (Natural Audio Profile) AAC Main, AAC LC, AAC SSR, AAC LTP, AAC Scalable, TwinVQ, CELP, HVXC, TTSI, ER AAC LC, ER AAC LTP, ER AAC Scalable, ER TwinVQ, ER BSAC, ER AAC LD, ER CELP, ER HVXC, ER HILN, ER Parametric 2000 Perfil de rede de áudio móvel (Mobile Audio Internetworking Profile) ER AAC LC, ER AAC Scalable, ER TwinVQ, ER BSAC, ER AAC LD 2000 Perfil HD-AAC (HD-AAC Profile) AAC LC, SLS 2009 Perfil Simples de ELA (ALS Simple Profile) ALS 2010
Armazenamento e transporte de áudio +Formatos multiplex, de armazenamento e de transmissão para áudio MPEG-4 Padrão Descrição Multiplex ISO/IEC 14496-1 Esquema MPEG-4 Multiplex (M4Mux) Multiplex ISO/IEC 14496-3 Multiplex de transporte de áudio de baixa sobrecarga (Low Overhead Audio Transport Multiplex) (LATM) Armazenar (Storage) ISO/IEC 14496-3 (informativo) Audio Data Interchange Format (ADIF) – somente para AAC Armazenar (Storage) ISO/IEC 14496-12 MPEG-4 file format (MP4) / Formato de arquivo de mídia base ISO Transmissão (Transmission) ISO/IEC 14496-3 (informativo) Audio Data Transport Stream (ADTS) – somente para AAC Transmissão (Transmission) ISO/IEC 14496-3 Low Overhead Audio Stream (LOAS), baseado em LATM Não há um padrão para o transporte de fluxos elementares por um canal, porque a ampla gama de aplicações MPEG-4 tem requisitos de entrega muito amplos para serem facilmente caracterizados com uma única solução.
As capacidades de uma camada de transporte e a comunicação entre as funções de transporte, multiplex e demultiplex são descritas no Delivery Multimedia Integration Framework (DMIF) na ISO/IEC 14496-6. Existe uma grande variedade de mecanismos de entrega abaixo desta interface, por exemplo, fluxo de transporte MPEG, Protocolo de Transporte em Tempo Real (RTP), etc.
O transporte no Protocolo de Transporte em Tempo Real é definido no RFC 3016 (Formato de Carga Útil RTP para Fluxos de Áudio/Visual MPEG-4), RFC 3640 (Formato de Carga Útil RTP para Transporte de Fluxos Elementares MPEG-4), RFC 4281 (Parâmetro de Codecs para Tipos de Mídia "Bucket") e RFC 4337 (Registro de Tipo MIME para MPEG-4).
LATM e LOAS foram definidos para aplicações de áudio natural, que não exigem codificação sofisticada baseada em objetos ou outras funções fornecidas pelos sistemas MPEG-4.
Bifurcação no padrão técnico AAC