Cryptograghic Message Syntax (CMS) — это стандарт IETF для защищенных крипто-сообщений. Он используется криптографическими системами и протоколами для цифровой подписи, хеширования, аутентификации, или шифрования различных форм цифровой информации.
CMS основан на синтаксисе PKCS #7, который в свою очередь основан на стандарте Privacy-Enhanced Mail. Стандарт CMS (2009) описан в RFC 5652.
Архитектура CMS построена на управлении ключами с помощью сертификатов, утвержденных сообществом PKIX.
CMS используется как криптографический элемент для многих стандартов, например S/MIME, PKCS #12, RFC 3161 (цифровая подпись временных меток).
OpenSSL является открытой библиотекой способной шифровать, расшифровывать, подписывать и проверять подпись, сжимать и разархивировать файлы с CMS.
См. также CAdES — CMS Advanced Electronic Signature S/MIME
PKCS #7
Ссылки RFC 8933 RFC 5652 RFC 6268 RFC 5753 RFC 3278 RFC 5084
Категория:Криптографические протоколы Категория:Стандарты Интернета