Ping — утилита для проверки целостности и качества соединений в сетях на основе TCP/IP, а также обиходное название запроса.
Утилита отправляет ICMP Echo-Request-запросы указанному узлу и регистрирует получаемые ICMP Echo-Reply. Время между отправкой запроса и получением ответа (, RTT) позволяет оценивать задержки на маршруте и процент потерь пакетов, что косвенно отражает загруженность каналов передачи данных и промежуточных устройств.
В разговорной речи термин «пинг» также обозначает время передачи пакета (в миллисекундах) между клиентом и серверомЧто такое пинг? // Интернет-провайдер в Киеве..
Этимология Название происходит от английского обозначения звука импульса, издаваемого сонаром. Первоначально термин «ping» (по созвучию) применялся для обозначения направленного акустического сигнала, используемого противолодочными гидролокаторами (также известными как «асдики», , аббревиатура от ).
Другая версия этимологии связывает название с игрой пинг‑понг, в которой мяч отыгрывается между игроками. По аналогии, компьютер и сервер обмениваются командами и ответами, как мяч переходит от одного игрока к другому.
Пример При диагностике сетевого соединения программа ping используется для проверки целостности и качества связи посредством отправки ICMP Echo-запросов. Ответы (ICMP Echo-Reply) анализируются для оценки потерь пакетов и задержек на маршруте. Например, получение небольшого количества ответов (около 30 или менее) может свидетельствовать о нестабильной работе сетевого оборудования и потенциальных проблемах с безопасностью. В таких случаях рекомендуется проверить политику безопасности IP, брандмауэр, групповую политику и настройки сетевого адаптера и роутера. При этом ping служит для проверки целостности и качества связи, а не для измерения скорости передачи данных, которую определяют транспортные протоколы TCP и UDP.
Обычный эхо-запрос имеет длину 64 байта (без учета 20 байт IP-заголовка). Согласно стандарту RFC 791, суммарный размер пакета в IPv4 не может превышать 65 535 байт.
Полное отсутствие ICMP-ответов может свидетельствовать о том, что удалённый узел или один из промежуточных маршрутизаторов блокирует ICMP Echo-Reply или игнорирует ICMP Echo-Request.
Программа ping является одним из основных диагностических средств в сетях TCP/IP и входит в состав всех современных сетевых операционных систем. Функциональность ping также реализована во встроенных операционных системах маршрутизаторов, а доступ к результатам выполнения ping по протоколу SNMP определяется RFC 2925 (Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations).
Поскольку для отправки ICMP-пакетов требуется создание raw-сокетов, для выполнения программы ping в системах UNIX необходимы права суперпользователя. Чтобы обычные пользователи могли использовать ping, для файла /bin/ping устанавливается SUID-бит.
История Программа была написана Майком Мууссом, учёным Исследовательской лаборатории баллистики () США в декабре 1983 года.
Практическое использование IP-адрес можно определить по доменному имени, однако при первом обращении происходит запрос к DNS-серверу, если указан хост. Программа ping позволяет проверить работоспособность сервера. Например, системный администратор может определить, завис ли только веб-сервер или имеются проблемы с хостом. С помощью ping можно проверить наличие связи с сервером. Примером может служить сравнение результатов запроса по доменному имени и по IP-адресу, что помогает выявить проблемы с настройкой DNS-серверов. Кроме того, ping позволяет оценить качество канала связи, определяя процент утраченных пакетов. Этот показатель важен для онлайн-игроков, хотя низкий процент ответов не всегда свидетельствует о проблемах с качеством связи, поскольку в некоторых сетях протокол ICMP может иметь низкий приоритет или быть полностью заблокирован.
См. также arping fping traceroute pathping
Примечания
Ссылки История программы ping словами автора, Майка Муса Веб-интерфейс для ping RFC 792 Распределённый Ping из нескольких мест — Точки расположены в множестве стран. Ping Test Online Проверка ping из различных частей мира — Множество точек мониторинга на территории РФ.
Категория:TCP/IP Категория:Unix Категория:Взаимодействие и службы Windows Категория:Администрирование компьютерных сетей Категория:Анализ компьютерных сетей