DHCP ( — протокол динамической настройки узла) — сетевой протокол, позволяющий сетевым устройствам автоматически получать IP-адрес и другие параметры, необходимые для работы в сети TCP/IP. Данный протокол работает по модели «клиент-сервер». Для автоматической конфигурации компьютер-клиент на этапе конфигурации сетевого устройства обращается к так называемому серверу DHCP и получает от него нужные параметры. Сетевой администратор может задать диапазон адресов, распределяемых сервером среди компьютеров. Это позволяет избежать ручной настройки компьютеров сети и уменьшает количество ошибок. Протокол DHCP используется в большинстве сетей TCP/IP.
DHCP является расширением протокола BOOTP, использовавшегося ранее для обеспечения бездисковых рабочих станций IP-адресами при их загрузке. DHCP сохраняет обратную совместимость с BOOTP и, как и BOOTP, использует порт UDP/67 на стороне сервера и порт UDP/68 на стороне клиента.
История Стандарт протокола DHCP был принят в октябре 1993 года. Действующая версия протокола (март 1997 года) описана в RFC 2131. Новая версия DHCP, предназначенная для использования в среде IPv6, носит название DHCPv6 и определена в RFC 3315 (июль 2003 года).
Распределение IP-адресов Протокол DHCP предоставляет три способа распределения IP-адресов: Ручное распределение. При этом способе сетевой администратор сопоставляет аппаратному адресу (для Ethernet-сетей это MAC-адрес) каждого клиентского компьютера определённый IP-адрес. Фактически данный способ распределения адресов отличается от ручной настройки каждого компьютера лишь тем, что сведения об адресах хранятся централизованно (на сервере DHCP), и потому их проще изменять при необходимости. Автоматическое распределение. При данном способе каждому компьютеру на постоянное использование выделяется произвольный свободный IP-адрес из определённого администратором диапазона. Динамическое распределение. Этот способ аналогичен автоматическому распределению за исключением того, что адрес выдаётся компьютеру не на постоянное пользование, а на определённый срок. Это называется арендой адреса. По истечении срока аренды IP-адрес вновь считается свободным, и клиент обязан запросить новый (он, впрочем, может оказаться тем же самым). Кроме того, клиент сам может отказаться от полученного адреса.
Некоторые реализации службы DHCP способны автоматически обновлять записи DNS, соответствующие клиентским компьютерам, при выделении им новых адресов. Это производится при помощи протокола обновления DNS, описанного в RFC 2136.
Опции DHCP Помимо IP-адреса, DHCP также может сообщать клиенту дополнительные параметры, необходимые для нормальной работы в сети. Эти параметры называются опциями DHCP. Список стандартных опций можно найти в RFC 2132.
Поле опций имеет переменную длину, однако DHCP-клиент должен быть готов принять DHCP-сообщение длиной в 576 байт (в этом сообщении поле options имеет длину 340 байт).
Поле опций начинается с «волшебного числа» — четырёх байт со значениями 99, 130, 83, 99 (0x63, 0x82, 0x53, 0x63 в шестнадцатеричной системе), позволяющие серверу определить наличие этого поля.
Каждая опция кодируется последовательностью «код» (один байт), «длина» (один байт), «значение» — поле переменной длины, размер которого равен значению поля «длина», в том числе может быть нулевым.
Исключения сделаны для двух кодов:
код 0 — используются для выравнивания. После него отсутствует поле «длина»
код 255 (0xFF) — означает конец списка опций. Этот код обязательно должен присутствовать последним. За ним также не следует поля «длина»
+ Список опций DHCP Код Длина Описание 0 (отсутствует) используется для заполнения и выравнивания данных 1 4 Маска подсети 2 4 Часовой пояс, число со знаком, смещение от UTC в секундах. 3 4 * n Список шлюзов, в порядке предпочтения. 4 4 * n Список серверов времени 5 4 * n Список серверов имён IEN 116. 6 4 * n Список серверов DNS 7 4 * n Список лог-серверов (MIT-LCS UDP) 8 4 * n Список cookie-серверов (RFC 865) 9 4 * n Список LPR-серверов (RFC 1179) 10 4 * n Список серверов Imagen Impress 11 4 * n Список серверов обнаружения ресурсов (RFC 887) 12 n Хост-имя клиента, строка. 13 2 Размер (в 512-октетных блоках) загрузочного образа для клиента 14 n Путь файла, где клиент сохраняет дамп при сбоях 15 n Имя домена 16 4 Swap-сервер 17 n Путь корневого каталога для клиента. 18 n Путь расширений BOOTP 19 1 Должен ли клиент включить IP форвардинг (принимает значение 1 или 0) 20 1 Должен ли клиент включить форвардинг датаграмм из нелокальных источников (принимает значение 1 или 0) 21 8 * n Список допустимых адресов сетей и масок для нелокальных источников 22 2 Максимальный размер датаграммы (минимальное значение 576) 23 1 Значение TTL для IP по-умолчанию 24 4 Таймаут (в секундах) устаревания значений Path MTU (RFC 1191) 25 2 * n Список значений MTU при выполнении Path MTU Discovery (RFC 1191) 26 2 Значение MTU для данного интерфейса (минальное значение 68) 27 1 Признак, что все подсети используют текущую конфигурацию MTU (принимает значение 0 или 1) 28 4 Широковещательный адрес 29 1 Признак, должен ли клиент запросить маску подсети посредством ICMP (принимает значение 0 или 1) 30 1 Признак, должен ли клиент отвечать на запросы маски посредством ICMP (принимает значение 0 или 1) 31 1 Признак, должен ли клиент запрашивать роутеры используя механизм RFC 1256 (принимает значение 0 или 1) 32 4 Адрес, на который клиент должен направлять запросы роутеров 33 8 * n Статичный список маршрутизации, состоит из пар «адрес назначения» — «адрес роутера». 34 1 Признак допустимости использования трейлеров при запросах ARP (принимает значение 0 или 1) 35 4 Таймаут кэша ARP, в секундах. 36 1 Признак необходимости использования инкапсуляции IEEE 802.3 (RFC 1042) вместо Ethernet Version 2 (RFC 894) (принимает значение 0 или 1) 37 1 Значение TTL для TCP по-умолчанию 38 4 Интервал времени (в секундах) перед отправкой пакета Keepalive 39 1 Признак, должны ли запросы Keepalive отправляться с дополнительным мусорным октетом (принимает значение 0 или 1) 40 n Имя домена NIS (строка) 41 4 * n Список серверов NIS 42 4 * n Список серверов времени NTP 43 n Специфичная для поставщика информация 44 4 * n Список серверов имён (NBNS) NetBIOS 45 4 * n Список серверов распределения датаграмм (NBDD) NetBIOS 46 1 Тип узла NetBIOS: 0x1 — B-node; 0x2 — P-node; 0x4 — M-node; 0x8 — H-node 47 n Область NetBIOS 48 4 * n Список серверов X Window System Font 49 4 * n Список адресов X Window System Display 50 4 Запрашиваемый IP-адрес 51 4 Время аренды IP-адреса, в секундах 52 1 Признак использования полей 'file' (1) и 'sname' (2) или обоих (3) для опций 53 1 Тип сообщения DHCP (1 — DHCPDISCOVER; 2 — DHCPOFFER; 3 — DHCPREQUEST; 4 — DHCPDECLINE; 5 — DHCPACK; 6 — DHCPNAK; 7 — DHCPRELEASE; 8 — DHCPINFORM) 54 4 Идентификатор DHCP сервера 55 n Список запрашиваемых параметров (каждый байт — код параметра) 56 n Текстовое сообщение об ошибке (строка) 57 2 Максимальный размер сообщения DHCP. Минимальное значение 576 58 4 Время T1, до обновления IP адреса (в секундах) 59 4 Время T2, до перепривязки (в секундах) 60 n Идентификатор типа поставщика (строка) 61 n Идентификатор клиента (строка) 64 n Имя домена NIS+ 65 4 * n Список серверов NIS+ 66 n Имя сервера TFTP (строка), если поле 'sname' используется для опций 67 n Имя загрузочного файла (строка), если поле 'file' используется для опций 68 4 * n Список адресов Mobile IP Home Agent 69 4 * n Список серверов SMTP 70 4 * n Список серверов POP3 71 4 * n Список серверов NNTP 72 4 * n Список WWW серверов 73 4 * n Список серверов Finger 74 4 * n Список серверов IRC 75 4 * n Список серверов StreetTalk 76 4 * n Список серверов StreetTalk Directory Assistance1084CLAT в сеть IPv6-only используя NAT64 (работает на iOS, MacOS, Android) для совместимости со старыми legacy приложениями согласно RFC8925 255 (отсутствует) Конец списка опций
Некоторыми из наиболее часто используемых опций являются: IP-адрес маршрутизатора по умолчанию; маска подсети; адреса серверов DNS; имя домена DNS.
Некоторые поставщики программного обеспечения могут определять собственные, дополнительные опции DHCP.
Устройство протокола Протокол DHCP является клиент-серверным, то есть в его работе участвуют клиент DHCP и сервер DHCP. Передача данных производится при помощи протокола UDP. По умолчанию запросы от клиента делаются к серверу на порт 67, сервер в свою очередь отвечает клиенту на порт 68, выдавая адрес IP и другую необходимую информацию, такую, как сетевую маску, маршрутизатор и серверы DNS.
Структура сообщений DHCP Все сообщения протокола DHCP разбиваются на поля, каждое из которых содержит определённую информацию. Все поля, кроме последнего (поля опций DHCP), имеют фиксированную длину.
Поле Описание Длина (в байтах) op Тип сообщения. Например может принимать значения: BOOTREQUEST (0x01, запрос от клиента к серверу) и BOOTREPLY (0x02, ответ от сервера к клиенту). 1 htype Тип аппаратного адреса. Допустимые значения этого поля определены в RFC 1700 «Assigned Numbers». Например, для MAC-адреса Ethernet это поле принимает значение 0x01. 1 hlen Длина аппаратного адреса в байтах. Для MAC-адреса Ethernet —0x06. 1 hops Количество промежуточных маршрутизаторов (так называемых агентов ретрансляции DHCP), через которые прошло сообщение. Клиент устанавливает это поле в 0x00. 1 xid Уникальный идентификатор транзакции в 4 байта, генерируемый клиентом в начале процесса получения адреса. 4 secs Время в секундах с момента начала процесса получения адреса. Может не использоваться (в этом случае оно устанавливается в 0x0000). 2 flags Поле для флагов — специальных параметров протокола DHCP. 2 ciaddr IP-адрес клиента. Заполняется только в том случае, если клиент уже имеет собственный IP-адрес и способен отвечать на запросы ARP (это возможно, если клиент выполняет процедуру обновления адреса по истечении срока аренды). 4 yiaddr Новый IP-адрес клиента, предложенный сервером. 4 siaddr IP-адрес следующего сервера в цепочки сервисов. Сервер может вернуть в этом поле свой собственный адрес. Для идентификации сервера используется опция 54. 4 giaddr IP-адрес агента ретрансляции, если таковой участвовал в процессе доставки сообщения DHCP до сервера. 4 chaddr Аппаратный адрес (обычно MAC-адрес) клиента. 16 sname Необязательное имя сервера в виде нуль-терминированной строки. 64 file Необязательное имя файла на сервере, используемое бездисковыми рабочими станциями при удалённой загрузке. Как и sname, представлено в виде нуль-терминированной строки. 128 options Поле опций DHCP. Здесь указываются различные дополнительные параметры конфигурации. В начале этого поля указываются четыре особых байта со значениями 99, 130, 83, 99 («волшебные числа»), позволяющие серверу определить наличие этого поля. Поле имеет переменную длину, однако DHCP-клиент должен быть готов принять DHCP-сообщение длиной в 576 байт (в этом сообщении поле options имеет длину 340 байт). переменная
Пример процесса получения адреса Рассмотрим пример процесса получения IP-адреса клиентом от сервера DHCP. Предположим, клиент ещё не имеет собственного IP-адреса, но ему известен свой предыдущий адрес — 192.168.1.100. Процесс состоит из четырёх этапов. Эти этапы часто сокращаются как DORA (Discovery, Offer, Request, и Acknowledgement)
Обнаружение DHCP Вначале клиент выполняет широковещательный запрос по всей физической сети с целью обнаружить доступные DHCP-серверы. Он отправляет сообщение типа DHCPDISCOVER (значение опции «Тип сообщения» — 1), при этом в качестве IP-адреса источника указывается 0.0.0.0 (если компьютер ещё не имеет собственного IP-адреса), а в качестве адреса назначения —широковещательный адрес 255.255.255.255.
Клиент заполняет несколько полей сообщения начальными значениями: В поле xid помещается уникальный идентификатор транзакции, который позволяет отличать данный процесс получения IP-адреса от других, протекающих в то же время. В поле chaddr помещается аппаратный адрес (MAC-адрес) клиента.