NTP ( — протокол сетевого времени) — сетевой протокол для синхронизации внутренних часов компьютера с использованием сетей с переменной . Протокол был разработан , профессором Делавэрского университета, в 1985 году. Версия на 2015 год — NTPv4RFC 5905.
NTP, основанный на алгоритме Марзулло, использует для своей работы протокол UDP и учитывает время передачи. Система NTP чрезвычайно устойчива к изменениям латентности среды передачи. В версии 4 способен достигать точности 10 мс (1/100 с) при работе через Интернет, и до 0,2 мс (1/5000 с) и лучше внутри локальных сетей.
Наиболее широкое применение протокол NTP находит для синхронизации серверов точного времени. Для достижения максимальной точности предпочтительна постоянная работа программного обеспечения NTP в режиме системной службы. В семействе операционных систем Microsoft Windows — это служба W32Time, в UNIX-подобных системах — демон Ntpd или chronyd.
Более простая реализация этого алгоритма известна как SNTP — простой протокол сетевого времени. Используется во встраиваемых системах и устройствах, не требующих высокой точности, а также в пользовательских программах точного времениRFC 4330.
Структура пакета Структура пакета описана в RFC 5905. Пакет состоит из целого числа 32-битных слов.
Данные в заголовке будут отличаться для различных режимов работы. Например, клиент в поля часовой слой, идентификатор источника, начальное время и время приёма должен записать нули.
Заголовок +Заголовок NTP Отступ Октет 0 1 2 3 Октет Бит 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0 0ИКВерсияРежимЧасовой слойИнтервал опросаТочность 4 32Задержка 8 64Дисперсия 12 96Идентификатор источника 16 128Время обновления 20 160 24 192Начальное время 28 224 32 256Время приёма 36 288 40 320Время отправки 44 352
Индикатор коррекции
Длина — 2 бита, от . Целое число, показывающее предупреждение о секунде координации. {| class="wikitable" ! Значение ! Описание |- | 0 | Нет предупреждения |- | 1 | Последняя минута дня содержит 61 секунду |- | 2 | Последняя минута дня содержит 59 секунд |- | 3 | Неизвестно (время не синхронизировано)
Номер версии Длина — 3 бита, от . Целое число, представляющее версию протокола.
Режим Длина — 3 бита, от . Целое число, представляющее режим. Значения представлены в таблице ниже. {| class="wikitable" ! Значение ! Описание |- | 0 | Зарезервировано |- | 1 | Симметричный активный режим |- | 2 | Симметричный пассивный режим |- | 3 | Клиент |- | 4 | Сервер |- | 5 | Широковещательный режим |- | 6 | Контрольное сообщение NTP |- | 7 | Зарезервировано для частного использования
Часовой слой Длина — 8 бит, от . Целое число, представляющее часовой слой. {| class="wikitable" ! Значение ! Описание |- | 0 | Не определено или недопустим |- | 1 | Первичный сервер |- | 2-15 | Вторичный сервер, использующий NTP |- | 16 | Не синхронизировано |- | 17-255 | Зарезервировано
Интервал опроса Длина — 8 бит, от . Целое число со знаком, представляющее максимальный интервал между последовательными сообщениями. Значение равно двоичному логарифму секунд. Предлагаемые по умолчанию пределы на минимальные и максимальные опросы — 6 и 10, соответственно.
Точность Длина — 8 бит, от . Целое число со знаком, представляющее точность системных часов. Значение равно двоичному логарифму секунд. Например, значению −18 будет соответствовать точность около 1 мкс.
Задержка Длина — 32 бита, от . Общее время распространения сигнала в обе стороны в коротком формате NTP.
Дисперсия Длина — 32 бита, от . Общая дисперсия для источника времени в коротком формате NTP.
Идентификатор источника Длина — 32 бита, от . Код источника синхронизации. Зависит от значения в поле Часовой слой. Для слоя 0 — это четыре ASCII символа, называемые «kiss code», используются для отладки и мониторинга. Смотри ниже Для слоя 1 — это четыре октета ASCII символов, дополненные слева нулями, назначенные для опорного времени. В таблице ниже представлен список, поддерживаемый IANA. {| class="wikitable" ! ID ! Источник |- | GOES | Геостационарный спутник системы экологического мониторинга и наблюдения |- | GPS | Система глобального позиционирования |- | GAL | Система местоопределения «Галилео» |- | PPS
| IRIG | , США |- | WWVB | , Колорадо, США |- | DCF | Низкочастотный радиопередатчик, 77.5 кГц, DCF77, Майнфлинген, ФРГ |- | HBG | , Швейцария |- | MSF | , Великобритания |- | JJY | Низкочастотный радиопередатчик, 40 кГц, Фукусима, 60 кГц, Сага, Япония |- | LORC | Среднечастотный радиопередатчик, 100 кГц, радионавигация, |- | TDF | , Франция |- | CHU | , Канада |- | WWV | , США |- | WWVH | , США |- | NIST | Телефонный модем Национального института стандартов и технологий США |- | ACTS | Телефонный модем Национального института стандартов и технологий США |- | USNO | Телефонный модем Национальной обсерватории США |- | PTB | Телефонный модем |} Для слоя 2 и выше — это идентификатор сервера и может быть использован для фиксирования временных петель. Если используется IPv4, то идентификатор представляет собой четыре октета IP адреса. Если используется IPv6, то это первые четыре октета MD5 хэша адреса. При использовании IPv6 адресов для сервера с NTPv4 и клиента с NTPv3 идентификатор может принимать случайное значение, из-за чего временные петли могут быть не зафиксированы.
Время обновления Длина — 64 бита, от . Время, когда система последний раз устанавливала или корректировала время. Формат NTP.
Начальное время Длина — 64 бита, от . Время клиента, когда запрос отправляется серверу. Формат NTP.
Время приёма Длина — 64 бита, от . Время сервера, когда запрос приходит от клиента. Формат NTP.
Время отправки Длина — 64 бита, от . Время сервера, когда запрос отправляется клиенту. Формат NTP.
NTP-сообщение «Kiss-o'-Death» Для слоя 0, который считается неопределённым или недопустимым, поле Идентификатор источника может использоваться для доставки сообщений, которые выполняют роль данных о состоянии системы и управления доступом. Такие сообщения называются «Kiss-o'-Death»От «Kiss of Death», что в переводе значит «последний удар» или «последняя попытка». (KoD), а доставляемые ими ASCII-данные называются «kiss codes» (коды «помощи»). Перечень принятых в настоящее время кодов «помощи» представлен в таблице ниже.
Получатели KoD-сообщений обязаны их проверить и выполнить следующие действия:
При получении кодовых комбинаций DENY и RSTR клиент обязан разорвать виртуальные соединения с данным сервером времени и прекратить передачу сообщений этому серверу. При получении кодовой комбинации RATE клиент обязан незамедлительно снизить свой интервал опроса этого сервера и продолжать его уменьшать каждый раз при получении этой кодовой комбинации. При получении кодовой комбинации начинающейся с ASCII-символа Х, предназначенной для проведения экспериментальных исследований и последующих усовершенствований, она должна быть проигнорирована, если она не распознаётся. Все другие кодовые комбинации и KoD-сообщения, не определённые данным протоколом, уничтожаются после их поверки.
+ Коды «помощи» Код Описание ACST Виртуальное соединение установлено одноадресным сервером AUTH Аутентификация сервером завершилась отказом AUTO Autokey-последовательность некорректна BCST Виртуальное соединение установлено широковещательным сервером CRYP Криптографическая аутентификация или идентификация завершились отказом DENY Удалённый сервер отказал в доступе DROP Потеря удаленного сервера времени в симметричном режиме RSTR Отказ в доступе вследствие локальной стратегии безопасности INIT Виртуальное соединение с первого раза не установлено MCST Виртуальное синхросоединение установлено динамически обнаруженным сервером NKEY Ключ не найден (либо он никогда ранее не загружался, либо он является ненадёжным) RATE Скорость превышена. Сервер временно запретил доступ, так как клиент превысил порог скорости RMOT Изменение виртуального соединения со стороны удалённого IP-узла, использующего NTP-протокол напрямую STEP Произошла итерация по изменению системного времени, виртуальное синхросоединение не установлено
Часовые слои
NTP использует иерархическую сеть, где каждый уровень имеет свой номер, называемый слой (). Слой 1 — первичные серверы, непосредственно синхронизирующиеся с национальными службами времени через спутник, радио или телефонный модем. Слой 2 — вторичные серверы, синхронизируются с первичными серверами, и т. д. Как правило, клиенты и серверы NTP с относительно небольшим числом клиентов не синхронизируется с первичными серверами. Существует несколько сотен общественных вторичных серверов, работающих на более высоких слоях. Они являются предпочтительным выбором.
Формат времени Время представляется в системе NTP 64-битным числом (8 байт), состоящим из 32-битного счётчика секунд и 32-битного счётчика долей секунды, позволяя передавать время в диапазоне 232 секунд, с теоретической точностью 2−32 секунды. Поскольку шкала времени в NTP повторяется каждые 232 секунды (136 лет), получатель должен хотя бы примерно знать текущее время (с точностью 68 лет). Также следует учитывать, что время отсчитывается с полуночи 1 января 1900 года, а не с 1970, поэтому из времени NTP нужно вычитать 70 лет (с учётом високосных лет), чтобы корректно совместить время с Windows или Unix-системами.
+ Короткий формат времени Бит 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0СекундыДоли секунд
+ Обычный формат времени Бит 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0Секунды 4Доли секунд
+ Формат даты Бит 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 0Номер эры 4Отступ эры 8Доли 12
См. также Служба точного времени Дисперсия Аллана OpenNTPD Синхронизация часов Протокол точного времени
Заметки
Примечания
Литература
Миллс, Дэвид Л. Сличение времени в компьютерных сетях. Протокол сетевого времени на Земле и в космосе. — Киев : Wircom, 2011. — С. 464. — ISBN 978-966-97191-0-2. Другие версии RFC: RFC 778, RFC 891, RFC 956, RFC 958, RFC 1305, RFC 2030, RFC 4330
Ссылки
Категория:Протоколы прикладного уровня Категория:Интернет-протоколы Категория:Часы