Служебная запись (SRV-запись) — стандарт в DNS, определяющий местоположение, то есть имя хоста и номер порта серверов для определённых служб. Определяется в RFC 2782. Некоторые Интернет-протоколы, такие как SIP и XMPP, часто требуют поддержки SRV-записей.
Формат записи SRV-запись имеет такой формат: _service._proto.name TTL class SRV priority weight port target
service: символьное имя сервиса. proto: транспортный протокол используемый сервисом, как правило TCP или UDP. name: доменное имя, для которого эта запись действует. TTL: стандарт DNS, время жизни. class: стандарт DNS, поле класса (это всегда IN). SRV: Тип записи (всегда SRV). priority: приоритет целевого хоста, более низкое значение означает более предпочтительный. weight: относительный вес для записей с одинаковым приоритетом. port: Порт TCP или UDP, на котором работает сервис. target: каноническое имя машины, предоставляющей сервис.
Пример записи SRV, которую можно найти в файлах зоны: _sip._tcp.example.com. 86400 IN SRV 0 5 5060 sipserver.example.com.
Эта запись указывает на сервер с именем sipserver.example.com, на котором прослушивается TCP-порт 5060 для предоставления SIP-услуг. Приоритет здесь имеет значение 0, а вес равен 5.
Как и в MX-записях, хост в SRV-записи должен указывать на адрес (A- или AAAA-запись). Hostname-псевдоним (CNAME-запись, :en:CNAME record) не может быть использован как допустимый параметр.
Ссылки Координационный центр национального домена сети Интернет DNS Resources Directory Ресурсы, посвящённые DNS & BIND Рабочий комитет IETF, занимающийся разработкой расширенной спецификации DNS (DNSEXT)
Документы RFC RFC 1034 — Domain Names — Concepts and Facilities RFC 1035 — Domain Names — Implementation and Specification RFC 1537 — Common DNS Data File Configuration Errors RFC 1591 — Domain Name System Structure and Delegation RFC 1713 — Tools for DNS Debugging RFC 2606 — Reserved Top Level DNS Names RFC 2782 — A DNS RR for specifying the location of services (DNS SRV)
Категория:DNS