ISO 639-1:2002 «Коды для обозначения названий языков, часть 1: коды Альфа-2» — первая часть стандарта серии ISO 639 международных стандартов для кодов языков. Часть 1 содержит регистрацию двухбуквенных кодов. Всего зарегистрировано 183 двухбуквенных кода, которые не покрывают всё мировое разнообразие языков.
Эти коды являются полезным формальным международным обозначением языков для стенографии. Например: Английский язык обозначается en (от English) Французский язык обозначается fr (от French) Немецкий язык обозначается de (от самоназвания Deutsch) Итальянский язык обозначается it (от Italian) Японский язык обозначается ja (от , хотя его самоназвание ) Португальский язык обозначается pt (от Portuguese) Русский язык обозначается ru (от ) Испанский язык обозначается es (от самоназвания español) Шведский язык обозначается sv (от самоназвания Svenska)
Первый стандарт для кодов языков ISO 639 был утверждён в 1967 году. Он был поделён на части, а в 2002 году появилась первая редакция отдельного стандарта ISO 639-1. Последнее добавление в стандарт было сделано 26.02.2003, когда был введён код ht, обозначающий гаитянский креольский язык. Использование стандарта было инспирировано специальной комиссией интернет-разработок (IETF) по языковым тегам, которая ввела запрос комментариев RFC 1766 в марте 1995 года, продолжила обсуждение в запросе RFC 3066 от января 2001 года и в запросе RFC 4646 от сентября 2006 года. Текущая версия RFC 5646 датирована сентябрём 2009 года. Права на коды ISO 639-1 зарегистрированы на Международный информационный центр по терминологии.
В 1998 году был разработан стандарт ISO 639-2, содержащий трёхбуквенные коды языков. В настоящее время новые двухбуквенные коды в стандарт ISO 639-1 не добавляются, если существует код этого языка в ISO 639-2, поэтому системы, которые используют коды языков ISO 639-1 и 639-2, предпочитают коды ISO 639-1, потому что их не придётся менять.
Если используется код ISO 639-2, который охватывает группу языков, он может измениться для некоторых конкретных языков нового кода ISO 639-1.
+ Коды, добавленные после публикации RFC в январе 2001ISO 639-1ISO 639-2НазваниеДата добавленияПрежде входил в составioidoИдо2002-01-15artwawlnВаллонский2002-01-29roalilimЛимбургский2002-08-02gemiiiiiНосу2002-10-14sitanargАрагонский2002-12-23roahthatГаитянский креольский2003-02-26cpf
Стандарт ISO 639-3, опубликованный в 2007 году, вводит понятие макроязыка (семейства языков), но не содержит трактовку их спецификаций.
См. также Список кодов ISO 639-1 ISO 639
Примечания
Ссылки ISO 639-1/RA ISO 639-2 Registration Authority FAQ
639-1