Telnet je sieťový komunikačný protokol založený na TCP s in-band signalizáciou. Začal sa vyvíjať od roku 1969 počínajúc RFC 0015 a bol štandardizovaný ako IETF STD 8 (RFC 854 a RFC 855), jeden z prvých internetových štandardov.
Jeho účelom je poskytovať pomerne všeobecný obojsmerný prostriedok komunikácie s osembitovým slovom. Primárnym cieľom je poskytnúť štandardizované rozhranie prostredníctvom siete pre terminálové zariadenia a terminálovo orientované procesy. Tiež je možné jeho využitie na komunikáciu medzi terminálmi navzájom a medzi procesmi navzájom.RFC 854
Telnet je protokol klient-server, využíva TCP štandardne na porte 23. Medzi aplikácie patria prístup k aplikáciám, MUD hrám, talkerom a BBS.
Bežnou aplikáciou bolo vzdialené prihlasovanie k terminálu, telnet však prenáša údaje v čisto textovej forme, preto ho v tejto aplikácii z dôvodov bezpečnosti nahradil protokol ssh. Hoci rozšírenia protokolu už definujú TLS zabezpečenie a SASL autentifikáciu, väčšina implementácií ich nepodporuje a prevažuje používanie ssh.
Referencie
Iné projekty
Externé odkazy Telnet Options - Officiálny zoznam priradených čísel volieb na iana.org
Kategória:Internetové_protokoly