Ogg je otvorený multimediálny kontajnerový formát.

Dátový formát Ogg, bol vytvorený ako slobodný formát pre digitálne multimédia, ktorý nie je obmedzený softvérovými patentmi a umožní efektívne ukladať alebo streamovať multimediálne obsahy. Práve streaming médií je silná stránka formátu Ogg. Všetko čo obsahuje Ogg kontajner je možné streamovať bez ďalších úprav, na rozdiel od ostatných formátov ktoré sa nedajú streamovať (napr. MP4) alebo ktoré sa dajú streamovať len po úprave (napr. matroska).

Formát Ogg je definovaný v RFC 3533 a jeho MIME typ application/ogg v RFC 3534, a spadá pod BSD licenciu.

Vývoj je spravovaný nadáciou Xiph.org, ktorá zodpovedá aj za vývoj jednotlivých kodekov, pomocou ktorých je komprimovaný multimediálny obsah kontajnera. ´

Kodeky Ogg Keďže Ogg je len multimediálny kontajner ktorý umožňuje zabaliť do jedného súboru rozličné typy dát, na komprimáciu multimediálnych dát sú potrebné kodeky. Ogg umožňuje zabaliť rozličné formáty napr. MPEG-4, MP3 atď., ale väčšinou sa používa s nasledovnými slobodnými kodekmi spravovanými nadáciou Xiph.org:

Audio Stratová kompresia dát Speex: pre nahrávky hlasu na nízkych bitových rýchlostiach (~8–32 kbit/s kanál) Vorbis: pre všeob. audio dáta na stredných až vysokých variabilných bitových rýchlostiach (~16 – 500 kbit/s kanál) Opus: určený pre hlas, hudbu a všeob. audio na variabilných bitových rýchlostiach (~6 – 510 kbit/s kanál) Bezstratová kompresia FLAC: určený na archiváciu, editáciu a internetovú distribúciu nahrávok, umožňuje streamovanie médií Bez kompresie OggPCM: nekomprimované PCM audio, podobne ako WAV

Video Stratová kompresia Theora: je založená na kodeku VP3 od On2 Technologies. Tarkin: experimentálny video kodek Dirac: slobodný video formát vyvinutý BBC Research & Development, založený je na waveletovej kompresii Bezstratová kompresia Dirac: časť špecifikácií dirac-u pokrýva aj bezstratovú kompresiu Bez kompresie OggUVS: kodek vo vývoji

Text Ogg Writ: textový kodek určený pre titulky OggKate: pre karaoke Continuous Media Markup Language(CMML): časovaný text. kodek, štruktúrou sa podobá na HTML Annodex: Otvorené štandardy pre značkovanie a indexovanie sieťovaných médií

Externé odkazy (v angličtine) Nadácia Xiph.Org — Oficiálne webové stránky RFC 3533 — Definícia formátu Ogg RFC 5334 — Typy médií v Ogg kodeky pre Windows Media Player: Vorbis, Speex, Theora, FLAC Online nástroj na konverziu súborov Ogg MiroVideoConverter

Iné projekty

Kategória:Multimediálne kontajnery Kategória:Slobodný softvér Kategória:Súborové formáty