Підмережа (), або підмережа мережі (), є логічним підрозділом IP-мережі. Updated by RFC 6918. Практика поділу мережі на дві або більше мереж називається сегментацією мережі ().

Комп'ютери, що належать до однієї підмережі, адресуються ідентичною групою найстарших значущих бітів своїх IP-адрес. У результаті відбувається логічний поділ IP-адреси на два поля: номер мережі або префікс маршрутизації, та поле залишку або ідентифікатор вузла. Поле залишку є ідентифікатором конкретного хоста або мережевого інтерфейсу.

Префікс маршрутизації може бути виражений як перша адреса мережі, записана в нотації безкласової міждоменній маршрутизації (CIDR), після якої ставиться символ похилої риски (/) і довжина префікса в бітах. Наприклад, є префіксом мережі Internet Protocol version 4, що починається із заданої адреси, має 24 біти, виділені для мережевого префікса, а решту 8 бітів зарезервовано для адресації вузлів. Адреси в діапазоні від до належать цій мережі, причому є її широкомовною адресою. Специфікація адреси IPv6 є великим блоком адрес із 296 адресами, що має 32-бітовий префікс маршрутизації.

Для IPv4 мережу також можна охарактеризувати її маскою підмережі або мережевою маскою (), яка є бітовою маскою, що при застосуванні за допомогою операції побітового AND до будь-якої IP-адреси в мережі дає префікс маршрутизації. Маски підмережі також виражаються в точково-десятковій нотації, як і IP-адреса. Наприклад, префіксу відповідає маска підмережі .

Обмін даними між підмережами здійснюється через маршрутизатори, коли префікси маршрутизації адреси джерела та адреси призначення відрізняються. Маршрутизатор слугує логічною або фізичною межею між підмережами.

Переваги підмережування наявної мережі залежать від конкретного сценарію розгортання. В архітектурі розподілу адрес Інтернету, що використовує CIDR, а також у великих організаціях необхідний ефективний розподіл адресного простору. Підмережування також може підвищити ефективність маршрутизації або мати переваги в керуванні мережею, коли підмережі в межах великої організації адміністративно контролюються різними суб'єктами. Підмережі можуть бути логічно організовані в ієрархічну архітектуру, розділяючи адресний простір мережі організації на деревоподібну структуру маршрутизації або на інші структури, такі як сітки.

Адресація та маршрутизація мережі

Комп'ютери, що беруть участь в IP-мережі, мають принаймні одну мережеву адресу. Зазвичай ця адреса є унікальною для кожного пристрою і може бути налаштована автоматично мережевою службою за допомогою протоколу динамічної конфігурації вузла (DHCP), вручну адміністратором або автоматично операційною системою за допомогою автоматичного налаштування адрес без збереження стану.

Адреса виконує функції ідентифікації вузла та визначення його розташування в мережі під час маршрутизації призначення. Найпоширенішою архітектурою мережевої адресації є Internet Protocol version 4 (IPv4), але його наступник, IPv6, дедалі ширше впроваджується приблизно з 2006 року. IPv4-адреса складається з 32 бітів. IPv6-адреса складається зі 128 бітів. В обох архітектурах IP-адреса поділяється на дві логічні частини: мережевий префікс та ідентифікатор вузла. Усі вузли підмережі мають однаковий мережевий префікс. Цей префікс займає старші значущі біти адреси. Кількість бітів, виділених у мережі для префікса, може відрізнятися між підмережами залежно від архітектури мережі. Ідентифікатор вузла є унікальним локальним ідентифікатором і є або номером вузла в локальній мережі, або ідентифікатором інтерфейсу.

Ця структура адресації дає змогу вибірково здійснювати маршрутизацію IP-пакетів через декілька мереж за допомогою спеціальних шлюзових комп'ютерів, які називаються маршрутизаторами, до вузла призначення, якщо мережеві префікси вузлів-джерел та вузлів-призначень відрізняються, або надсилати їх безпосередньо до цільового вузла в локальній мережі, якщо вони однакові. Маршрутизатори утворюють логічні або фізичні межі між підмережами та керують трафіком між ними. Кожну підмережу обслуговує визначений маршрутизатор за замовчуванням, але внутрішньо вона може складатися з декількох фізичних сегментів Ethernet, з'єднаних між собою мережевими комутаторами.

Префікс маршрутизації адреси визначається маскою підмережі, записаною в тій самій формі, що й IP-адреси. Наприклад, маска підмережі для префікса маршрутизації, що складається зі старших 24 бітів IPv4-адреси, записується як .

Сучасною стандартною формою визначення мережевого префікса є нотація CIDR, що використовується як для IPv4, так і для IPv6. Вона визначає кількість бітів у префіксі та додає це число до адреси після символу похилої риски (/). Цю нотацію було запроваджено разом із безкласовою міждоменній маршрутизацією (CIDR). У IPv6 це єдина заснована на стандартах форма позначення мережевих або маршрутних префіксів.

Наприклад, мережа IPv4 з маскою підмережі записується як , а нотація IPv6 позначає адресу та її мережевий префікс, що складається зі старших 32 бітів.

У класовій мережевій адресації IPv4, до запровадження CIDR, мережевий префікс можна було безпосередньо отримати з IP-адреси на основі її старшої послідовності бітів. Це визначало клас (A, B, C) адреси і, відповідно, маску підмережі. Однак після запровадження CIDR призначення IP-адреси мережевому інтерфейсу потребує двох параметрів: адреси та маски підмережі.

Маючи адресу джерела IPv4, пов'язану з нею маску підмережі та адресу призначення, маршрутизатор може визначити, чи знаходиться призначення в локально підключеній мережі або у віддаленій мережі. Маска підмережі призначення не потрібна і зазвичай невідома маршрутизатору. Updated by RFC 1349, RFC 4379, RFC 5884, RFC 6093, RFC 6298, RFC 6633, RFC 6864, RFC 8029. Для IPv6, однак, визначення локального підключення відрізняється в деталях і потребує протоколу виявлення сусідів (NDP). Призначення IPv6-адреси інтерфейсу не вимагає відповідності префіксу локального підключення, і навпаки, за винятком локальних адрес каналу.

Оскільки кожна локально підключена підмережа має бути представлена окремим записом у таблицях маршрутизації кожного підключеного маршрутизатора, підмережування збільшує складність маршрутизації. Однак завдяки ретельному проєктуванню мережі маршрути до сукупностей більш віддалених підмереж у гілках деревоподібної ієрархії можна агрегувати в супермережу та представити окремими маршрутами.

Див. також Автономна система (Інтернет) Сегментація мережі

Примітки

Посилання