__NOTOC__ ONC RPC (), також відома як Sun RPC — система викликів віддалених процедур, початково розроблена Sun Microsystems у 1980-х роках як частина проекту Network File System.
ONC RPC заснована на конвенції викликів функцій для операційних систем типу Unix і мови програмування C. Серіалізація даних відбувається за допомогою репрезентації XDR. Відправлення повідомлень по мережі відбувається або у складі дагаграм UDP, або у пакетах TCP. Доступ до сервісів RPC забезпечується за допомогою спеціальної програми через мережний порт номер 111 (TCP і UDP).
Неофіційними стандартами, що описують ONC RPC, є RFC 1831 (1995 рік) і RFC 5531 (2009 рік, поточна версія). Механізми автентифікації у ONC RPC описані у документах RFC 2695, RFC 2203, і RFC 2623.
Реалізації ONC RPC існують у більшості Unix-подібних операційних систем. Одна з реалізацій для Microsoft Windows, написана самою Microsoft, постачалася у складі пакету ; існують також реалізації для Windows від сторонніх фірм, включно з такими, що на додачу до C / C++ підтримують також мови Java і Microsoft .NET.
Див. також XML-RPC
Джерела