thumb|Croissance du nombre d'AS sur Internet depuis 1997. Un (abrégé AS), ou système autonome, est un ensemble de réseaux informatiques IP intégrés à Internet et dont la politique de routage interne (routes à choisir en priorité, filtrage des annonces) est cohérente.
Un AS est généralement sous le contrôle d'une entité ou organisation unique, typiquement un fournisseur d'accès à Internet.
Chaque AS est identifié par un numéro de 16 bits (ou 32 depuis 2007, selon la ) , appelé « Autonomous System Number » (ASN). Il est affecté par les organisations qui allouent les adresses IP, les registres Internet régionaux (RIR). En Europe, c'est le RIPE-NCC qui assume cette charge, par délégation de l'IANA.
Les numéros d'AS (les ASN) sont utilisés par le protocole de routage Border Gateway Protocol (BGP) entre les systèmes autonomes (les AS). Ils furent historiquement conçus en 1982 pour le prédécesseur de BGP (le protocole EGP).
Au sein d'un AS, le protocole de routage « interne » de type IGP (notamment OSPF ou IS-IS) permet aux routeurs de cet AS de communiquer entre eux, et plus particulièrement en vue de monter des sessions BGP internes (iBGP).Entre systèmes autonomes, le routage est « externe », en BGP externe (eBGP).
En général, lASN n'apparait pas dans les protocoles de routage internes (les IGP) puisque, par définition, ils sont limités à un seul AS. Cependant, certains protocoles de routage internes, tels que Enhanced Interior Gateway Routing Protocol (EIGRP), sont configurés pour n'établir d'adjacence qu'avec les routeurs qui annoncent le même système autonome.
Le nombre dAS composant Internet dépassait en 1999, fin 2008, mi-2010 Tony Bates, Philip Smith, Geoff Huston, « CIDR REPORT for 14 Jan 11 », lire en ligne., plus de en mai 2013 , plus de en 2019. Le nombre d'''AS alloués (utilisés ou pas sur Internet) était quant à lui de plus de en 2019.
Numéros dAS spéciaux Les numéros réservés pour un usage privé ne doivent pas être utilisés pour un réseau relié à Internet IANA: Autonomous System (AS) Numbers, Consulté le 21 août 2013..
Lors de l'introduction des numéros d’AS à , certains équipements (appelés "old speakers") n'étaient compatibles qu'avec les numéros dAS à . Pour pallier ce problème, l'ASN23456 (également appelé AS_TRANS) a été réservé pour permettre l'appairage entre les routeurs de bordure compatibles avec les ASN de ("new speakers''") et ceux qui sont incompatibles IETF: BGP Support for Four-Octet Autonomous System (AS) Number Space, Consulté le 21 août 2013..
Numéro/Plage d'AS (en décimal) Numéro/Plage d'AS (en hexadécimal) Description Référence 0 0x0000 Réservé Codification of AS 0 processing. 23456 0x5BA0 AS_TRANS RFC 6793 64496-64511 (16 numéros) 0xFBF0-0xFBFF (0x0010 numéros) Réservé à l'usage dans la documentation et les codes d'exemple RFC 5398 64512-65534 (1023 numéros) 0xFC00-0xFFFE (0x03ff numéros) Réservé pour un usage privé RFC 6996 65535 0xFFFF Réservé 65536-65551 (16 numéros) 0x00010000-0x0001000F (0x0010 numéros) Réservé à l'usage dans la documentation et les codes d'exemple RFC 5398 65552-131071 (65520 numéros) 0x00010010-0x0001FFFF (0xFFF0 numéros) Réservé 4200000000-4294967294 (94967295 numéros) 0xFA56EA00 -0xFFFFFFFE (0x05A915FF numéros) Réservé pour un usage privé RFC 6996 4294967295 0xFFFFFFFF Réservé
Notes et références
Voir aussi Default-free zone Border Gateway Protocol (BGP) Enhanced Interior Gateway Routing Protocol (EIGRP) Open Shortest Path First (OSPF)
Catégorie:Architecture d'Internet Catégorie:Réseau informatique Catégorie:Automation