En seguridade informática, as siglas AAA corresponde a un tipo de protocolos que realizan tres funcións: Autenticación, Autorización e Contabilización (Authentication, Authorization and Accounting en inglés). A expresión protocolo AAA non se refire pois a un protocolo en particular, senón a unha familia de protocolos que ofrecen os tres servizos citados.
AAA combínase ás veces con auditoría, converténdose entón en AAAA.
Autenticación A autenticación é o proceso polo que unha entidade proba a súa identidade ante outra. Normalmente a primeira entidade é un cliente (usuario, ordenador etc) e a segunda un servidor (ordenador). A Autenticación conséguese mediante a presentación dunha proposta de identidade (vg. un nome de usuario) e a demostración de estar en posesión das credenciais que permiten comprobala. Exemplos posibles destas credenciais son as contrasinais, as testemuñas dun só uso (one-time tokens), os Certificados Dixitais, ó os números de teléfono na identificación de chamadas. Vén ao caso mencionar que os protocolos de autenticación dixital modernos permiten demostrar a posesión das credenciais requiridas sen necesidade de transmitilas pola rede (véxanse por exemplo os protocolos de desafío-resposta).
Autorización A autorización refírese á concesión de privilexios específicos (incluíndo "ningún") a unha entidade ou usuario baseándose na súa identidade (autenticada), os privilexios que solicita, e o estado actual do sistema. As autorizacións poden tamén estar baseadas en restricións, tales como restricións horarias, sobre a localización da entidade solicitante, a prohibición de realizar logins múltiples simultáneos do mesmo usuario etc. A maior parte das veces o privilexio concedido consiste no uso dun determinado tipo de servizo. Exemplos de tipos de servizo son, pero sen estar limitado a: filtrado de enderezos IP, asignación de enderezos, asignación de rutas, asignación de parámetros de Calidade de Servizo, asignación de Ancho de banda, e Cifrado.
Contabilización A contabilización refírese ao seguimento do consumo dos recursos de rede polos usuarios. Esta información pode usarse posteriormente para a administración, planificación, facturación, ou outros propósitos. A contabilización en tempo real é aquela na que os datos xerados entréganse ao mesmo tempo que se produce o consumo dos recursos. En contraposición a contabilización por lotes (en inglés "batch accounting") consiste na gravación dos datos de consumo para a súa entrega nalgún momento posterior. A información típica que un proceso de contabilización rexistra é a identidade do usuario, o tipo de servizo que se lle proporciona, cando comezou a usalo, e cando terminou.
Lista de protocolos AAA
RADIUS. DIAMETER. TACACS. TACACS+.
Outros protocolos utilizados en combinación cos protocolos AAA:
PPP. EAP. LDAP.
Requisitos
RFC 2194 Review of Roaming Implementations. RFC 2477 Criteria for Evaluating Roaming Protocols. RFC 2881 Network Access Server Requirements Next Generation (NASREQNG) NAS Model. RFC 2903 Generic AAA Architecture. RFC 2904 AAA Authorization Framework. RFC 2905 AAA Authorization Application Examples. RFC 2906 AAA Authorization Requirements. RFC 3169 Criteria for Evaluating Network Access Server Protocols. RFC 3539 AAA Transport Profile. RFC 1234 AAA Transport Profile.
Categoría:Seguridade informática