X.25 — стандарт передачи данных с использованием коммутации пакетов. Стандарт описывает протоколы трёх уровней: физического, канального (LAPB) и пакетного (PLP), что соответствует физическому, канальному, и сетевому уровню сетевой модели OSI. Предназначался для организации WAN на основе телефонных сетей с линиями с достаточно высокой частотой ошибок, поэтому содержит развитые механизмы коррекции ошибок. Ориентирован на работу с установлением соединений. Исторически является предшественником протокола Frame Relay.
X.25 обеспечивает множество независимых виртуальных каналов (Permanent Virtual Circuits, PVC и Switched Virtual Circuits, SVC) в одной линии связи, идентифицируемых в X.25-сети по идентификаторам подключения к соединению, идентификаторам логического канала (Logical Channel Identifier, LCI) или номеру логического канала (Logical Channel Number, LCN).
Благодаря надёжности технологии и его работе поверх телефонных сетей общего пользования X.25 широко использовался как в корпоративных сетях, так и во всемирных специализированных сетях предоставления услуг, таких как SWIFT (банковская платёжная система, прекратили использование в 2005 году) и SITA ( — система информационного обслуживания воздушного транспорта), однако в настоящее время X.25 вытесняется другими технологиями канального уровня (Frame Relay, ISDN, ATM) и протоколом IP, оставаясь, однако, достаточно распространённым в странах и территориях с неразвитой телекоммуникационной инфраструктурой.
MTU для X.25 равно 576 байт. Также это число считается минимальным размером дейтаграммы, которую должен уметь принять и обработать любой хост в интернете.RFC 791, p. 24, «Every internet destination must be able to receive a datagram of 576 octets either in one piece or in fragments to be reassembled.»
История и стандартизация Разработан Исследовательской комиссией VII Международного консультативного комитета по телеграфии и телефонии (МККТТ) (с 1993 года — Сектор стандартизации электросвязи Международного союза электросвязи (МСЭ-Т)) в качестве стандарта для пакетной передачи данных в телефонных сетях, принят в 1976 году, впоследствии стал основой всемирной системы PSPDN (), то есть WAN. Существенные дополнения к стандарту были приняты в 1984 году, в частности, для согласования имеющихся описанных уровней с опубликованной сетевой моделью OSI. В настоящее время для X.25 действует стандарт ISO 8208, а также стандартизовано применение пакетного уровня X.25 (протокол PLP) в локальных сетях (стандарт ISO 8881).
По мере распространения IP-сетей IETF стандартизовал ряд RFC, описывающих работу и взаимодействие X.25 и TCP/IP:
RFC 887 A Standard for the Transmission of IP Datagrams Over Public Data Networks RFC 1086 ISO-TP0 bridge between TCP and X.25 RFC 1090 SMTP on X.25 RFC 1356 Multiprotocol Interconnect on X.25 and ISDN in the Packet Mode RFC 1381 SNMP MIB Extension for X.25 LAPB RFC 1381 SNMP MIB Extension for the X.25 Packet Layer RFC 1461 SNMP MIB extension for Multiprotocol Interconnect over X.25 RFC 1598 PPP in X.25 RFC 1613 Cisco Systems X.25 over TCP (XOT)
Архитектура .------. | HOST | .---------. .-----. .-----. .-----. |---. | | Терм. |-----| DTE |=====| DCE |____________| DCE |=====|PAD| | | `---------' | `-----' : : `------'
"NATIVE" :---- Пакетная сеть ----: PROTOCOL
Режимы и типы пакетов X.25 Режим установления соединения (Call setup mode) используется при установлении соединения SVC между DTE-устройствами. В этом режиме на уровне PLP используется схема адресации X.121 для установления виртуального соединения. Режим установления соединения работает на уровне виртуальных каналов, то есть в пределах одного физического DTE-устройства одни SVC могут быть в состоянии установления соединения, а другие — в режиме передачи данных или разрыва соединения. Режим установления соединения используется только в случае установления SVC, но не PVC. Режим передачи данных (Data transfer mode) используется при передаче данных по виртуальному каналу. При этом X.25 PLP ответственен за сегментацию данных в пакеты и сборку пакетов, управление передачей данных и коррекцию ошибок. Режим передачи данных работает на уровне виртуальных каналов и используется в случае как SVC, так и PVC. Режим ожидания (Idle mode) характеризуется отсутствием передачи данных при установленном виртуальном канале. Работает на уровне виртуальных каналов и используется только в случае установления SVC, но не PVC. Режим разрыва соединения (Call clearing mode) используется при разрыве соединения SVC между DTE-устройствами. Работает на уровне виртуальных каналов и используется только в случае разрыва SVC, но не PVC. Режим перезапуска (Restarting mode) используется для переустановки соединений между DTE-устройством и локально работающих с ним DCE-устройствами. В отличие от других режимов, выполняется в пределах одного физического DTE-устройства, что сопровождается разрывом всех виртуальных каналов, установленных с этим DTE.
+ Типы пакетов X.25Packet TypeDCE DTEDTE DCEServiceVCPVCУстановление и разрыв соединенийIncoming CallCALL REQ Запрос соединенияXCall ConnectedCALL ACC Вызов принятXClear IndicationCLR REQ Запрос разрываXClear ConfirmationCLR CNF Подтверждение разрываXДанные и прерыванияDataData Пакет данныхXXInterruptINT REQ Запрос прерыванияXXInterrupt ConfirmationINT CNF Подтверждение прерыванияXXFlow Control and ResetReciever ReadyRR Приёмник готовXXReciever Not ReadyRNR Приёмник не готовXXREJ ОтказXXReset IndicationRES REQ Запрос сбросаXXReset ConfirmationRES CNF Подтверждение сбросаXXRestartRestart IndicationRSTR REQ Запрос перезапускаXXRestart ConfirmationRSTR CNF Подтверждение перезапускаXXDiagnosticDIAG ДиагностикаXXRegistrationREG CNF Подтверждение регистрацииREG REQ Запрос регистрацииXX
Стандарты ГОСТ ГОСТ Р ИСО/МЭК 10177-99 — Информационная технология. Передача данных и обмен информацией между системами. Обеспечение промежуточными системами внутренних услуг сетевого уровня в режиме с установлением соединения при использовании протокола пакетного уровня X.25 по ГОСТ Р 34.950 ГОСТ Р 34.950-92 — Информационная технология. Взаимосвязь открытых систем. Передача данных. Протокол пакетного уровня X.25 для оконечного оборудования данных ГОСТ Р ИСО/МЭК 8881-98 — Информационная технология. Передача данных. Использование протокола пакетного уровня X.25 в локальных вычислительных сетях ГОСТ 34.954-91 — Информационная технология. Взаимосвязь открытых систем. Использование протокола пакетного уровня X.25 для обеспечения услуг сетевого уровня взаимосвязи открытых систем в режиме с установлением соединения
См. также Frame Relay AX.25 — версия X.25 для радиолюбителей Перевод описания протокола X.25
Примечания
Ссылки Рекомендация МСЭ-Т X.25 на сайте Международного союза электросвязи
Категория:Сетевые протоколы Категория:Рекомендации ITU-T