DIAMETER — сеансовый протокол, созданный, отчасти, для преодоления некоторых ограничений протокола RADIUS. Обеспечивает взаимодействие между клиентами в целях аутентификации, авторизации и учёта различных сервисов (AAA, ). Является основным протоколом архитектуры IMS.

В основе протокола DIAMETER лежит концепция в создании базового протокола с возможностью его расширения для предоставления сервисов AAA при появлении новых технологий доступа.

Описание: RFC 6733 (Diameter Base Protocol), RFC 3589 (Diameter Command Codes for 3GPP), RFC 4006 (Diameter Credit-Control Application).

Сравнение с протоколом RADIUS Название DIAMETER — игра слов, отражающая превосходство нового протокола над предшественником RADIUS (диаметр — удвоенный радиус). Diameter не имеет обратной совместимости по отношению к RADIUS, но предоставляет механизмы миграции. Среди отличий между протоколами особенно выделяют: Поддержка транспортных протоколов с гарантированной доставкой (TCP или SCTP вместо UDP) TCP транспорт для RADIUS ещё в процессе стандартизации IETF Защита данных на сетевом и транспортном уровнях (IPsec или TLS) Transport Layer Security for RADIUS ещё в процессе стандартизации IETF Поддержка перехода с RADIUS, несмотря на то, что Diameter не полностью совместим с RADIUS Увеличенное адресное пространство для пар атрибут-значение (AVP) и идентификаторов (32 bit вместо 8 bit) Модель клиент-сервер. В качестве исключения, тем не менее, поддерживаются некоторые инициируемые сервером сообщения Поддержка stateful и stateless моделей использования Динамическое обнаружение узлов (используя DNS SRV и NAPTR) Возможность согласования функциональных возможностей узлов Поддержка механизмов надежной доставки на уровне приложений, описаны механизмы отказоустойчивости и state machine (RFC 3539) Сообщения об ошибках Улучшенная поддержка мобильности Улучшенная расширяемость; возможность использования пользовательских команд и атрибутов

См. также RADIUS TACACS TACACS+ PPP

Категория:Протоколы AAA Категория:Интернет-протоколы