vCard, також відомий як VCF (Virtual Contact File) — стандартний формат файлу для візиток. Їх часто приєднують до e-mail-ів, миттєвих сповіщень, текстових сповіщень (MMS), розміщують в Інтернеті, або передають за допомогою QR-кодів. Ці файли типово містять контактні дані як ім'я, адресу, номери телефонів, e-mail, фото тощо.

MIME-type для vCard є text/vcard, хоча існують і інші типи, залежно від версії.RFC 6350, section 10.1 «Media Type Registration» Додатково існують аналоги vCard, коли та ж інформація представлена в інших форматах, таких як XML, JSON або HTML.

Приклад vCard

Наведена візитівка однієї людині у форматі vCard 4.0 (RFC 6350).

BEGIN:VCARD VERSION:4.0 N:Gump;Forrest;;Mr.; FN:Forrest Gump ORG:Bubba Gump Shrimp Co. TITLE:Shrimp Man PHOTO;MEDIATYPE=image/gif:<nowiki>http://www.example.com/dir_photos/my_photo.gif</nowiki> TEL;TYPE=work,voice;VALUE=uri:tel:+1-111-555-1212 TEL;TYPE=home,voice;VALUE=uri:tel:+1-404-555-1212 ADR;TYPE=WORK;PREF=1;LABEL="100 Waters Edge\nBaytown\, LA 30314\nUnited States of America":;;100 Waters Edge;Baytown;LA;30314;United States of America ADR;TYPE=HOME;LABEL="42 Plantation St.\nBaytown\, LA 30314\nUnited States of America":;;42 Plantation St.;Baytown;LA;30314;United States of America EMAIL:[email protected] REV:20080424T195243Z x-qq:21588891 END:VCARD

Див. також

hCard

Примітки

Посилання Internet mail Consortium — Personal Data Interchange vCard: The Electronic Business Card (Version 2.1) vCard 2.1 specification (Sept-18-1996) Representing vCard Objects in RDF  — W3C ontology RFC 2425 — A MIME Content-Type for Directory Information RFC 2426 — vCard MIME Directory Profile RFC 2739 — Calendar Attributes for vCard and LDAP RFC 4122 — UUID URN namespace (could be used for UID type) RFC 4770 — vCard Extensions for Instant Messaging RFC 6350 — vCard Format Specification RFC 6351 — xCard: vCard XML Representation RFC 6473 — vCard KIND: application RFC 6474 — vCard Format Extensions: Place of Birth, Place and Date of Death RFC 6715 — vCard Format Extensions: Representing vCard Extensions Defined by the Open Mobile Alliance (OMA) Converged Address Book (CAB) Group RFC 6868 — Parameter Value Encoding in iCalendar and vCard RFC 7095 — jCard: The JSON Format for vCard IETF vCardDAV working group CSV to vCard contacts file converter