Запит коментарів, Прохання прокоментувати (, RFC) — документ із серії пронумерованих інформаційних документів Інтернету, що містить технічні специфікації та Стандарти, має широке застосування у всесвітній мережі. Назву «Request for Comments» ще можна перекласти як «заявка на обговорення» чи «тема для обговорення». Зараз публікацією документів RFC займається IETF під егідою відкритої організації Товариство Інтернету (, ISOC). Правами на RFC володіє якраз Товариство Інтернету.
Історія Формат RFC з’явився в 1969 році при обговоренні проекту ARPANET. RFC 1 був опублікований 7 квітня 1969 р. та називався «Host Software». Перші RFC поширювалися в друкованому вигляді як звичайні листи, але вже з грудня 1969 р., коли запрацювали перші сегменти ARPANET, документи почали розповсюджуватися в електронній формі.
Нарис історії RFC за 30 років з 1969 по 1999 роки показаний в RFC 2555.
Створення та життєвий цикл RFC Попри назву, запити коментарів RFC зараз розглядаються як стандарти Інтернету (а робочі версії стандартів називаються чернетками, від ). Згідно з RFC 2026, життєвий цикл стандарту такий: Виноситься на загальне обговорення Інтернетівська чернетка (). Чернетки не мають офіційного статусу та видаляються з бази через шість місяців після останньої зміни. Якщо чернетка стандарту виявляється досить вдалою, вона отримує статус Запропонованого стандарту () та свій номер RFC. Наявність програмної реалізації стандарту бажана, але не обов'язкова. Наступна стадія — Чорновий стандарт () означає, що пропонований стандарт прийнятий товариством та для нього існує щонайменше дві незалежні реалізації. Вищий рівень — Стандарт Інтернету () означає, що існує значна кількість різних реалізацій та успішний досвід використання.
Такі стандарти, поряд з нумерацією RFC, мають власну нумерацію STD.
Приклади популярних RFC Номер RFCТемаRFC 768 UDPRFC 791 IPRFC 792 ICMPRFC 793 TCPRFC 821 SMTP, замінений RFC 2821RFC 822 Формат електронної пошти, замінений RFC 2822RFC 826 Протокол визначення адреси (ARP)RFC 894 IP через EthernetRFC 951 Протокол початкового завантаження BOOTPRFC 959 FTPRFC 1034 DNS — концепціяRFC 1035 DNS — втіленняRFC 1122 Вимоги до хоста 1RFC 1123 Вимоги до хоста 2RFC 1191 Визначення шляху MTURFC 1256 Виявлення маршрутизатора в мережіRFC 1323 Високопродуктивний протокол TCPRFC 1350 TFTPRFC 1403 Взаємодія BGP та OSPFRFC 1459 IRCRFC 1498 Архітектурна дискусіяRFC 1518 Присвоєння адрес CIDRRFC 1519 Міждоменна маршрутизаціяRFC 1591 Структура доменних іменRFC 1661 PPPRFC 1738 URLRFC 1771 BGP версії 4RFC 1772 Застосування BGPRFC 1789 Телефонія через Інтернет (замінений стандартами VoIP)RFC 1812 Вимоги до маршрутизаторів IPv4RFC 1889 Транспорт реального часуRFC 1905 SNMPRFC 1907 SNMP версії 2RFC 1918 «Мережа 10»RFC 1939 Протокол POP версії 3 (POP3)RFC 2001 Розширення продуктивності TCPRFC 2026 Процес стандартизації в ІнтернетіRFC 2045 MIMERFC 2046RFC 2047RFC 2048RFC 2049RFC 2060 IMAP версії 4 (IMAP4), замінений RFC 3501RFC 2131 DHCPRFC 2223 Інструкції для авторів RFCRFC 2231 Кодування символівRFC 2328 OSPFRFC 2401 Архітектура безпекиRFC 2453 Routing Information Protocol, версія 2RFC 2516 PPPoERFC 2525 Проблеми TCPRFC 2535 Безпека DNSRFC 2581 Контроль заторів в TCPRFC 2616 HTTPRFC 2637 PPTPRFC 2663 Трансляція мережевих адресRFC 2766 NAT-PT (оголошено застарілим у RFC 4966)RFC 2821 SMTPRFC 2822 Формат електронної поштиRFC 2865 RADIUSRFC 2866 Засоби обрахунку RADIUSRFC 2960 SCTPRFC 3010 NFSRFC 3031 Архітектура MPLSRFC 3066 Мовні теґиRFC 3092 Етимологія «Foo»RFC 3098 Відповідальна реклама електронною поштоюRFC 3160 Гід по IETFRFC 3168 Explicit Congestion NotificationRFC 3261 SIPRFC 3501 IMAP версії 4 видання 1 (IMAP4rev1)RFC 4627 JSON
Див. також
Першоквітневі RFC RFC 768 - RFC українською мовою
Зноски
Посилання
Редактор RFC База даних RFC Офіційний статус стандартизації по різним RFC Запити RFC на сайті IETF Повний список RFC у текстовому форматі