A Routing Protocol е протокол кој специфицира како насочувачите комуницираат меѓусебе, ширејќи информации кои им овозможуваат да изберат правци на било кои два јазли на компјутерска мрежа, изборот на патот ќе биде направен од страна на насочувачки алгоритми. Секој насочувач има priori знаење само за мрежи кои се прикачени директно на него. Насочувачките протоколи оваа информација ја делат прво со непосредните соседи, а потоа и низ мрежата. На овој начин насочувачите се стекнуваат со знаење за топологијата на мрежата. За дискусија за концептите на насочувачките протоколи, посетете: Насочување
Поимот Насочување протоколи конкретно може да се однесува на една операција од трите слоја на OSI model, кој на сличен начин дистрибуира информации помеѓу насочувачи.
Иако постојан голем број на насочувачки протоколи, три главни класи се во широка употреба на IP мрежи : Interior gateway routing преку link-state routing protocols, како што се OSPF и IS-IS. Interior gateway routing преку path vector или distance vector протоколи, како што се RIP, IGRP и EIGRP. Exterior gateway routing. BGP v4 е насочувачки протокол кој се користи од Internet.
Многу насочувачки протоколи се дефинирани во документи наречени RFCs.INTERNET PROTOCOL, RFC 791, J Postel, September 1981.BROADCASTING INTERNET DATAGRAMS IN THE PRESENCE OF SUBNETS, RFC 922, Jeffrey Mogul, October 1984Towards Requirements for IP Routers, RFC 1716, P. Almquist, November 1994Requirements for IP Version 4 Routers, RFC 1812, F. Baker,June 1995
Специфичните одлики на насочувачките протоколи вклучуваат начинот на кој тие или ќе ги спречат насочувачките јамки од формирање или да ги паузираат ако го направат тоа начинот на кој тие ќе ги изберат најпосакуваните патишта, користејќи ги информациите за хоп трошоци времето што им е потребно да се спојат колку добро тие ќе се зголемат и многу други фактори
Routed наспроти routing protocols
Во некои случаи, насочувачките протоколи можат сами да работат во текот на т.н. изнесени протоколи: на пример, BGP работи во текот на TCP, кој пак работи во текот на IP; заштита е донесена во имплеменатцијата на овие системи не за да создаде кружна завистост помеѓу насочувачките и изнесени протоколи. Тоа дека насочувачкиот протокол работи во текот на поединечниот транспортен механизам не значи дека насочувачкиот протокол е од слој (N+1) ако транспортниот механизам е од слојот (N). Според OSI Routing framework, насочувачки протоколи се слој на протоколи за мрежниот протокол, без оглед на нивниот транспорт механизам:
IS-IS работи во текот на слојот за податочна врска OSPF (Open Shortest Path First), IGRP(Interior Gateway Routing Protocol), and EIGRP (Enhanced Interior Gateway Routing Protocol) работат директно преку IP; OSPF и EIGRP имаат свои сигурни транспорт механизми додека IGRP претставува несигурен транспорт. RIP (Routing Information Protocol) работи во текот на UDP (User Datagram Protocol) BGP (Border Gateway Protocol) работи во текот на TCP (Transmission Control Protocol)
Примери Внатренасочувачки протоколи
Interior Gateway Protocols (IGPs) разменуваат насочувачки информации во рамките на единствен насочувачки домен. Одреден автономен системGuidelines for creation, selection, and registration of an Autonomous System (AS), RFC 1930, J. Hawkison & T. Bates,March1996 може да содржи повеќе насочувачки домени, или збир од насочувачки домени може да биде координиран без да биде корисник на Интернет автономниот систем. Чести примери се: IGRP (Interior Gateway Routing Protocol) EIGRP (Enhanced Interior Gateway Routing Protocol) OSPF (Open Shortest Path First) RIP (Routing Information Protocol) IS-IS (Intermediate System to Intermediate System)
Имајте на ум дека IGRP, комерцијален Cisco насочувачки протокол, повеќе не е поддржано. EIGRP ги прифаќа IGRP конфигурациските команди. Поврзано Static routing Adaptive routing
Наводи
Натамошно читање Chapter "Routing Basics" in the Cisco "Internetworking Technology Handbook"
* Категорија:Computer networking *