8-би́тный код для обме́на и обрабо́тки информа́ции (сокр. КОИ-8) — восьмибитная кодовая страница, являющаяся расширением кодировки КОИ-7 (объединением наборов Н0 и Н1) и вследствие этого совместимая с ISO 646 IRV (ASCII), предназначенная для обмена и обработки информации с возможностью использования латинского и русского алфавитов. КОИ-8 была стандартизована в паре с ДКОИ в , утратившем силу 1 июля 1993 года, и в настоящее время не определена ни в одном из действующих стандартов. Один из вариантов КОИ-8 — KOI8-R — был широко распространён как основная русская кодировка в Unix-подобных операционных системах и в электронной почте, однако с конца 2000-х годов он постепенно выходит из употребления в связи с распространением Юникода.
Разработчики КОИ-8 разместили буквы русского алфавита в верхней половине кодовой таблицы так, чтобы их позиции совпадали с позициями фонетически аналогичных им латинских букв в нижней половине таблицы, поэтому русские буквы расположены не в алфавитном порядке. Благодаря этому при обнулении старшего (восьмого) бита символов текста, написанного в КОИ-8 (в частности, из-за прохождения через семибитную среду), получается относительно читаемый текст, подобный транслиту; так, например, слова «Русский Текст» превращаются в «rUSSKIJ tEKST».
Существует несколько расширенных вариантов КОИ-8 с поддержкой различных кириллических алфавитов; тем не менее, основной диапазон кодовых позиций кириллицы (—), содержащий 32 русские буквы (все кроме Ё) в обоих регистрах (строчные и прописные), во всех вариантах остаётся неизменным. Поддержка русского алфавита реализована в KOI8-R, украинского — в KOI8-U, белорусского — в KOI8-RU, таджикского — в KOI8-T.
В 1990-х годах KOI8-R фактически стала стандартом кодирования русской кириллицы в Unix-подобных операционных системах и в электронной почте. Автор данной кодировки (RFC 1489) Андрей Чернов в начале 1990-х годов работал в компании «Демос» (сеть «Релком») и непосредственно участвовал в запуске и наладке первого Интернет-канала между Россией и западными странами. KOI8-R в итоге стала первой стандартизованной русской кодировкой в Интернете.
IETF утвердил несколько RFC по расширенным вариантам КОИ-8, впоследствии зарегистрированным IANA в своём списке: RFC 1489 — KOI8-R (с поддержкой русского алфавита); RFC 2319 — KOI8-U (с поддержкой украинского алфавита); RFC 1345 — ISO-IR-111 (с ошибкой в расположении основного диапазона).
В Microsoft Windows KOI8-R присвоен идентификатор 20866, KOI8-U — 21866.
Кодовые таблицы Нижние половины кодовых таблиц (позиции —) полностью совпадают с ASCII. Числа под символами обозначают их шестнадцатеричный код в Юникоде.
KOI8-R (русская)
KOI8-U (русско-украинская) Здесь и далее приводятся только те строки кодовой таблицы, которые отличаются от KOI8-R.
KOI8-RU (русско-белорусско-украинская)
KOI8-C (центральноазиатская)
KOI8-T (таджикская)
KOI8-O, KOI8-S (русская дореформенная орфография)
ISO-IR-111, KOI8-E
KOI8-Unified, KOI8-F Кодировка KOI8-F предложена компанией Fingertip Software. Неразрывный пробел размещён сразу в двух кодовых позициях — и .
KOI8-M Кодировка KOI8-M представляет собой кодировку KOI8-R с символами псевдографики, расположенными в порядке, как в первоначальной (разработанной в ВЦ АН СССР) версии альтернативной кодировки.
Некириллические варианты КОИ-8 В некоторых странах — членах СЭВ создавались модификации КОИ-8 для национальных вариантов латиницы. Основная идея была та же — при «срезании» старшего бита текст должен оставаться более или менее понятным.
Примечания
Комментарии
Источники
Ссылки RFC 1489 (KOI8-R) RFC 2319 (KOI8-U) RFC 1345 (ISO-IR-111)
Категория:ГОСТ Категория:Кодировки кириллицы