El Protocolo de Internet versión 4 (, IPv4) es la cuarta versión del Internet Protocol (IP), un protocolo de interconexión de redes basados en Internet, y que fue la primera versión implementada en 1983 para la producción de ARPANET. Definida en el RFC 791, el IPv4 usa direcciones de 32 bits, limitadas a = 4 294 967 296 direcciones únicas, muchas de ellas LAN.http://tools.ietf.org/html/rfc1918 Por el crecimiento enorme que ha tenido la seguridad electrónica y la automatización, combinado con el hecho de que hay desperdicio de direcciones en muchos casos (consultar las secciones que siguen), ya hace varios años se observó que escaseaban las direcciones IPv4.
Esta limitación ayudó a estimular el estudio sobre la factibilidad de implantación de un nuevo protocolo IPv6, que en el año 2016 ya estaba en las primeras fases de pruebas, y que terminaría reemplazando al protocolo IPv4.
Las direcciones disponibles en la reserva global de IANA pertenecientes al protocolo IPv4 se agotaron oficialmente el jueves 3 de febrero de 2011. Los Registros Regionales de Internet debieron manejarse, desde ese momento, con sus propias reservas, que se estimaba alcanzarían hasta el año 2020 y no por mucho más tiempo.
Direccionamiento
derecha |300px |thumb |Descomposición de la representación de la dirección IPv4 de cuatro valores, a su equivalente binario.
El IPv4 utiliza direcciones de 32 bits que limitan el espacio de direcciones a (232) direcciones posibles.
El IPv4 (Protocolo de Internet versión 4) reserva bloques de direcciones especiales para redes privadas (en total direcciones, o sea, (224), así como direcciones de multidifusión ( direcciones, o sea, 228).
Representaciones de direcciones Las direcciones IPv4 pueden representarse en cualquier notación que exprese un valor entero de 32 bits. La mayoría de las veces se escriben en la notación decimal, la que consta de cuatro octetos de la dirección expresada individualmente en números decimales, y separados uno del siguiente por puntos.
Por ejemplo, la dirección IP de cuatro puntos 192.0.2.235 representa el número decimal de 32 bits 3221226219, que en formato hexadecimal es 0xC00002EB. Esto también puede expresarse en formato hexadecimal de puntos como 0xC0.0x00.0x02.0xEB, o con valores en formato octal como 0300.0000.0002.0353.
La notación CIDR combina la dirección con su prefijo de enrutamiento en un formato compacto, en el que a la dirección le sigue un carácter de barra (/) y el conteo de 1 bits consecutivos en el prefijo de enrutamiento (máscara de subred).
Asignación En el diseño original de IPv4, una dirección IP se dividió en dos partes: el identificador de red era el octeto más significativo de la dirección, y por su parte, el identificador de host (anfitrión o huésped) era el resto de la dirección. Este último también fue llamado el campo de descanso. Esta estructura permitía un máximo de 256 identificadores de red, que rápidamente se encontró que eran inadecuados.
Para superar este límite, el octeto de dirección más significativo se redefinió en 1981 para crear clases de red, en un sistema que más tarde se conoció como redes con clase. El sistema revisado definió cinco clases. Las clases A, B y C tenían diferentes longitudes de bits para la identificación de la red. El resto de la dirección se usó como anteriormente para identificar un host dentro de una red. Debido a los diferentes tamaños de campos en diferentes clases, cada clase de red tenía una capacidad diferente para direccionar a sus huéspedes. Además de las tres clases para direccionar hosts, la Clase D se definió para el direccionamiento de multidifusión, y la Clase E se reservó para aplicaciones futuras.
La división de las redes con clase existentes en subredes comenzó en 1985 con la publicación del RFC 950. Esta división se hizo más flexible con la introducción de máscaras de subred de longitud variable (VLSM) en el RFC 1109 en 1987. En 1993, basado en este trabajo, el RFC 1517 introdujo el Classless Inter-Domain Routing (CIDR), que expresa el número de bits (de los más significativos) como, por ejemplo, /24, y el esquema basado en clases se denominaba con clase, en contraste. El CIDR fue diseñado para permitir la repartición de cualquier espacio de direcciones, de modo que se pudieran asignar bloques de direcciones más pequeños o más grandes a los distintos usuarios. La estructura jerárquica creada por el CIDR fue administrada por la Autoridad de Números Asignados de Internet (IANA) y los registros regionales de Internet (RIR). Cada RIR mantiene una base de datos WHOIS de búsqueda pública, la que proporciona información sobre las asignaciones de direcciones IP.
Direcciones de uso especial El Grupo de Trabajo de Ingeniería de Internet (IETF) y la Autoridad de Números Asignados de Internet (IANA) han restringido el uso general de varias direcciones IP reservadas para fines especiales. En particular, estas direcciones se utilizan para el tráfico de multidifusión y para proporcionar espacio de direccionamiento para usos no restringidos en redes privadas.
+Bloques de direcciones especialesBloque de direccionesRangoNúmero de direccionesAlcanceDescripción0.0.0.0/80.0.0.0–0.255.255.25516.777.216SoftwareRed actual Updated by RFC 8190. (solo válido como dirección de origen).10.0.0.0/810.0.0.0–10.255.255.25516.777.216Red privadaUtilizado para las comunicaciones locales dentro de una red privada. Updated by RFC 6761.100.64.0.0/10100.64.0.0–100.127.255.2554.194.304Red privadaEspacio de direcciones compartido para las comunicaciones entre un proveedor de servicios y sus suscriptores cuando se utiliza un NAT de nivel de operador.127.0.0.0/8127.0.0.0–127.255.255.25516.777.216HostSe utiliza para las direcciones de loopback.169.254.0.0/16169.254.0.0–169.254.255.25565.536SubredSe utiliza para las direcciones de enlace local entre dos hosts en un solo enlace cuando de otra manera no se especifica una dirección IP, como normalmente se habría recuperado de un servidor DHCP.172.16.0.0/12172.16.0.0–172.31.255.2551.048.576Red privadaUtilizado para las comunicaciones locales dentro de una red privada.192.0.0.0/24192.0.0.0–192.0.0.255256Red privadaIETF Protocol Assignments.192.0.2.0/24192.0.2.0–192.0.2.255256DocumentaciónAsignada como TEST-NET-1, para documentación y ejemplos.192.88.99.0/24192.88.99.0–192.88.99.255256InternetReservada. Previamente usado para relay IPv6 a IPv4. Obsoleted by RFC 7526. (incluido el bloque de direcciones IPv6 2002::/16).192.168.0.0/16192.168.0.0–192.168.255.25565.536Red privadaUtilizado para las comunicaciones locales dentro de una red privada.198.18.0.0/15198.18.0.0–198.19.255.255131.072Red privadaSe utiliza para pruebas de referencia de comunicaciones entre dos subredes separadas. Updated by: RFC 6201 and RFC 6815.198.51.100.0/24198.51.100.0–198.51.100.255256DocumentaciónAsignado como TEST-NET-2, para documentación y ejemplos.203.0.113.0/24203.0.113.0–203.0.113.255256DocumentaciónAsignado como TEST-NET-3, para documentación y ejemplos.224.0.0.0/4224.0.0.0–239.255.255.255268.435.456InternetUsado para Multicast IP. (previamente una red clase D). (Experimental)240.0.0.0/4240.0.0.0–255.255.255.254268.435.456InternetReservada para usos futuros. Obsoletes RFC 1700. (anteriormente una red clase E). (Experimental)255.255.255.255/32255.255.255.2551SubredReservada para destinos multidifusión.
Redes privadas De los aproximadamente cuatro mil millones de direcciones definidas en IPv4, cerca de 18 millones de direcciones en tres rangos están reservadas para su uso en redes privadas. Las direcciones de paquetes en estos rangos no son enrutables en la Internet pública; son ignorados por todos los enrutadores públicos. Por lo tanto, los hosts privados no pueden comunicarse directamente con las redes públicas y requieren la traducción de direcciones de red en una puerta de enlace de enrutamiento para este propósito.
+ Rangos de red IPv4 reservados para redes privadasNombreBloque CIDRRango de direccionesNúmero de direccionesClasebloque de 24-bit10.0.0.0/810.0.0.0 – 10.255.255.255Clase A.bloque de 20-bit172.16.0.0/12172.16.0.0 – 172.31.255.255Rango contiguo de 16 bloques de clase B.bloque de 16-bit192.168.0.0/16192.168.0.0 – 192.168.255.255Rango contiguo de 256 bloques de clase C.
Dado que dos redes privadas, por ejemplo, dos sucursales, no pueden interoperar directamente a través de la Internet pública, las dos redes deben conectarse a través de Internet a través de una Red privada virtual o un túnel IP, que encapsula los paquetes, incluidos sus encabezados que contienen el Direcciones privadas, en una capa de protocolo durante la transmisión a través de la red pública. Además, los paquetes encapsulados se pueden cifrar para que la transmisión a través de redes públicas asegure los datos.
Direcciones de enlace-local
La RFC 3927 define el bloque de dirección especial 169.254.0.0/16 para el direccionamiento de enlace-local. Estas direcciones solo son válidas en enlaces (como un segmento de red local o conexión punto a punto) conectados a un host. Estas direcciones no son enrutables. Al igual que las direcciones privadas, estas direcciones no pueden ser el origen o destino de los paquetes que atraviesan Internet. Estas direcciones se utilizan principalmente para la configuración automática de direcciones (Zeroconf) cuando un host no puede obtener una dirección IP de un servidor DHCP u otros métodos de configuración interna.
Cuando se reservó el bloque de direcciones, no existían estándares para la configuración automática de direcciones. Microsoft creó una implementación llamada direccionamiento IP privado automático (APIPA), que se implementó en millones de máquinas y se convirtió en un estándar de facto. Muchos años después, en mayo de 2005, el IETF definió un estándar formal en RFC 3927, titulado Configuración dinámica de direcciones de enlace local IPv4.
Loopback
La red de clase A 127.0.0.0 (red sin clase 127.0.0.0/8) está reservada para loopback. Los paquetes IP cuyas direcciones de origen pertenecen a esta red nunca deben aparecer fuera de un host. El modus operandi de esta red se expande sobre el de una interfaz de loopback:
Los paquetes IP cuyas direcciones de origen y destino pertenecen a la red (o subred) de la misma interfaz de loopback se devuelven a esa interfaz; Los paquetes IP cuyas direcciones de origen y destino pertenecen a redes (o subredes) de diferentes interfaces del mismo host, uno de los cuales es una interfaz de loopback, se reenvían regularmente.
Direcciones terminadas en 0 o 255 Es posible que las redes con máscaras de subred de al menos 24 bits, es decir, redes Clase C en redes con clase, y redes con sufijos CIDR /24 a /30 (255.255.255.0–255.255.255.252) no tengan una dirección que termine en 0 o 255.
El direccionamiento con clase prescribió solo tres posibles máscaras de subred: Clase A, 255.0.0.0 o /8; Clase B, 255.255.0.0 o /16; y Clase C, 255.255.255.0 o /24. Por ejemplo, en la subred 192.168.5.0/255.255.255.0 (192.168.5.0/24) el identificador 192.168.5.0 se usa comúnmente para referirse a la subred completa. Para evitar la ambigüedad en la representación, la dirección que termina en el octeto 0 está reservada.
Una dirección multidifusión es una dirección que permite que la información se envíe a todas las interfaces en una subred determinada, en lugar de a una máquina específica. En general, la dirección de difusión se encuentra obteniendo el complemento de bits de la máscara de subred y realizando una operación OR a nivel de bits con el identificador de red. En otras palabras, la dirección de transmisión es la última dirección en el rango de direcciones de la subred. Por ejemplo, la dirección de transmisión para la red 192.168.5.0 es 192.168.5.255. Para redes de tamaño /24 o más, la dirección de transmisión siempre termina en 255.